When booting my Pi, I get an error that states: "Panic:VFS: Unable to mount root fs on unknown-block(179,2). It's rather annoying, and I've tried lots of various things, I've googled and searched, but nothing works for me. If anyone could help me with this ANNOYING problem, I would appreciate it quite a bit.


2 Answers 2


Did you perhaps transfer your image to a different card?

You may have copied a working image from one SD card to another slightly smaller card. Not all cards advertised as for instance 16 GB have the exact same number of blocks. When mounting the root partition at boot time the kernel then tries to read blocks which are beyond the size of the card.

In that case you need to shrink the Linux partition with resize2fs. Note that this only resizes the file system. You also have the shrink the partition in the partition table with parted or fdisk.

Another strategy is to take the card to a Linux PC and try to mount the root filesystem there. You may then be able to deduce what is wrong with it, run fsck if need be etc.


Since you were not being specific, I really don't know what lots of various things you had tried.

Regardless, this could be caused by some corruptions in the partition. If so, then you can do the following to fix the corruptions in the partition.

  1. Run a fsck -fy /dev/sdXn (where Xn is the partition for rootfs [ext, ext2, ext3, or ext4]).
  2. Run a dosfsck -aw /dev/sdXn (where Xn is the partition for boot [DOS]).

Once this is done, try to boot again to see if the problem gets resolved.

Not the answer you're looking for? Browse other questions tagged or ask your own question.