1

I'm using a custom wheezy binary by OLA (Open Lighting Architecture): https://www.openlighting.org/ola/tutorials/ola-on-raspberry-pi/

I tried enabling the boot into Desktop via sudo raspi-config - but when I reboot, it stays in Command Line.

I took a look at /boot/config.txt - but there are no options for GUI booting.

How can I boot into GUI?

  • Do you know if there's even a GUI installed on OLA's version? Usually they are enabled by default if they are. – goldilocks Apr 19 '15 at 16:09
  • You're right - there was no GUI installed on this build! – Josiah Apr 21 '15 at 7:58
1

Put startx in ~/.bash_profile. There are other ways of doing it but that's nice and simple. You may have to install it first if it's not included in your custom distribution of choice. (test if startx works from the command line first)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.