1

I just wanted to ask some advices. I have tried everything I could find, including :

  • /boot/config.txt add Line dtoverlay=w1-gpio,gpiopin=4
  • Update and Upgrade
  • Updating firmware
  • Buying new Sensors.
  • Tried Testing GPIO4 (Pin 7)
  • sudo modprobe w1-gpio && sudo modprobe w1_therm (always present)

I just cannot seem to get these sensors to pic up at all

I have rechecked my wiring and all seems Fine. was following this (Guide)

I tried testing GPIO4 with an LED and Python.. but I cannot seem to get it to switch state to .HIGH (Possibly Faulty GPIO pin?)/(Locked by Kernel?)

Any Assistance would be appreciated.

Images of Connections

  1. Connection to Raspberry Pi GPIOs

    Pin Connections on Raspberry Pi

  2. Breadboard Connections and layout

Bread board layout

  1. Different Angle as to see the Resistors Placement

Different Angle on breadboard

  1. gpiotest Results enter image description here
  • Could you post a photo of your set-up and could you detail the connections you have made between the Pi and the sensor(s). – joan Apr 28 '15 at 15:24
  • I will post Pictures now – Dean Retic Esterhuizen Apr 28 '15 at 15:55
  • Image of Breadboard Connections link<br> Image of GPIO pins link Image of Breadboard from the back Link – Dean Retic Esterhuizen Apr 28 '15 at 16:02
  • Could you edit your post and add those photos? It's more useful for subsequent readers. Also could you describe the connections you have made? It is easier to check a written description against the photos. – joan Apr 28 '15 at 16:09
  • As far as I can tell from the photos the connections look okay. One end of the resistor is connected to 3V3. Is the other connected to the data output pin? – joan Apr 28 '15 at 16:49
1

This happened to me today, after few hours I found the answer. :)

Add this line to /boot/config.txt:

device_tree=

Then restart the Pi. Hope this will fix for you too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.