6

I have tried every OS I can think of/am able to install (Windows 3, Android, and Debian, as well as XBMC). I have tried to install every Flash player - I could find. I have also downloaded multiple web browsers and still no success. How can I do it?

My goal is to play Spotify from the Raspberry Pi, preferably through a web browser, without needing to have a premium account like XBMC and despotify.

  • Flash should have burned years ago. But the problem is there is no proper DRM system that doesn't use Flash. Live video is sorted now with HTML5, Audio mostly too but lacks DRM. I don't think there is a Flash player for ARM, point, and Adobe just don't get with the times with this. The only way I see is to make a normal PC proxy sound to the Pi. Somehow play spotify there, capture and retransmit the audio on a RTSP or OGG protocol, possibly VLC. – Piotr Kula Apr 28 '15 at 21:39
6

You could try this. It is best used on the Raspberry Pi 2, because this is pure software rendered and will use a lot of CPU. You need to have Chromium installed.

wget http://odroidxu.leeharris.me.uk/PepperFlash-12.0.0.77-armv7h.tar.gz
tar -xzf PepperFlash-12.0.0.77-armv7h.tar.gz
cd PepperFlash
chmod +x *
sudo cp * /usr/lib/chromium/plugins
sudo nano  /etc/chromium/default

or later version. With the same steps as above, just replace version numbers as required.

wget http://odroidxu.leeharris.me.uk/PepperFlash-15.0.0.152.r2-armv7h.tar.gz

Uncomment the line starting with "CHROMIUM_FLAGS=". Add the following line.

CHROMIUM_FLAGS="--ppapi-flash-path=/usr/lib/chromium/plugins/libpepflashplayer.so --ppapi-flash-version=12.0.0.77 -password-store=detect -user-data-dir"
  • Save
  • Open Chromium
  • Enter chrome://plugins
  • The pepperflash-plugin should be visible. Enable it.
  • Done

Flash animations work well, Flash video to a certain degree, depending on video resolution. There are reports though that Spotify specifically may not work because of lack of NPAPI in Pepper Flash, but some recent changes may have fixed it.

| improve this answer | |
  • I get this after running "chmod +x * sudo cp * /usr/lib/chromium/plugins" "chmod: cannot access 'sudo': No such file or directory -> chmod: cannot access 'cp': No such file or directory -> chmod: changing permissions of '/usr/lib/chromium/plugins': Operation not permitted" Any thoughts? – Nicholas Laurita Apr 29 '15 at 5:56
  • That helped and I believe everything installed correctly. I am using chromium but unfortunately the plugin doesn't seam to be working/active? I get a message "couldn't load plug-in" when trying to connect to youtube, and with spotify it loads enough to allow me to log in, however a message appears on the screen "To enjoy spottily, please install Adobe Flash. It's free." Any thought about this one? – Nicholas Laurita Apr 29 '15 at 17:46
  • 1
    Awesome! well thank you so much for your help with everything!!! – Nicholas Laurita Apr 30 '15 at 1:49
  • 2
    I'm going to guess based on the armv7h part that this can only be used on the Pi 2. – goldilocks Nov 6 '15 at 20:25
  • 3
    Unsure about unable to post an answer, already got 101 reputation. Anyway here's the update. Above site is down - odroidxu.leeharris.me.uk. I was looking for a solution to this problem, this thread doesn't help anymore. I tried installing gnash and it's browser plugins browser-plugin-gnash with apt-install command which helped running some flash videos from youtube in Raspberry 2 wheezy debian version. Hope it helps. – Anmol Saraf Jan 2 '16 at 6:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.