I am aware that in many linux distributions you can setup multiple desktops or workspaces as a way of organization. I do not mean separate user accounts but one user account with multiple desktops. Is this possible in raspbian and if so how would I do it? This is the basic idea but I would like to do it with raspbian.

  • 2
    Note that you aren't limited to using LXDE; you can change the default DE on Raspian to something else, although with the limited memory on the pi you may want to avoid the heftier ones like GNOME and KDE. As per that article you linked, you can also have multiple DEs installed and running simultaneously with different logins (but that would be straining the RAM limitations even further).
    – goldilocks
    Apr 29, 2015 at 11:40
  • 1
    It's 2022 and this is a little different now. First off, open Preferences -> Main Menu Editor and add in some useful items to the Preferences menu. If you add in the "Openbox Configuration Manager" you can find a "Desktops" tab in there which allows you to add virtual desktops and name them. I think the key though is to run sudo update-alternatives --config x-session-manager and play around with those options. I selected "openbox" at one point but the "startlxde" option is what I've settled on. I can now add the "Desktop Pager" widget to my dock and have what I am after, more or less.
    – Randy L
    Mar 12, 2022 at 4:01

5 Answers 5


To set up multiple desktops do the following:

  1. Click Menu,
  2. Then Preferences;
  3. Then Windows Settings;
  4. From the Configuration manager choose Desktops in the left hand column;
  5. Select the desired Number of Desktops;
  6. Then click Close.

You now have multiple desktops, However, the GUI does not give any indication of this and you need to remember the keyboard shortcuts to use them: Ctrl + Alt + Left/Right will switch to the next desktop. To make this more usable do the following:

  1. Right Click on the menu bar at the top of the screen;
  2. Select Add/Remove Panel Items;
  3. Select the Panel Applets Tab;
  4. Click the Add button;
  5. Choose Desktop Pager from the list;
  6. Optional, choose Desktop Number/Workspace Name;
  7. Click Close.

This will add a panel applet to the menu bar (far right by default) that will allow you to click and switch between the desktops.

  • 2
    Ctr + Alt + Left/Right did not do anything on my vanilla/new/ Raspberry Pi 3 (tested with multiple keyboards). Jan 5, 2018 at 18:27
  • 3
    shift + alt + left/right worked ok for me. Jul 18, 2018 at 0:07
  • 3
    Hm, and what if my Preference menu does not have a Windows Settings item?
    – obachtos
    Mar 12, 2021 at 13:20
  • 1
    @obachtos you need to go to Preferences -> Main Menu Editor and add a few things to your Main Menu. There isn't any Windows Settings but some other interesting ones.
    – Randy L
    Mar 12, 2022 at 3:12

As of mid-2016, our fully-updated Raspbian Jessie would not respond to any so-far published fixes for the disappearing/unobtainable multiple desktop option in Raspbian, no matter what we tried with the Desktop Pager applet in the LXDE panel.

This seems to fix it for us:-

Install:- ' obconf '

...this is the OpenBox configurator. You can use: Menu > Preferences > Add/Remove Software, or type this in a terminal:

sudo apt-get update && sudo apt-get install obconf

Either way it will want your password..

When installed, do: Menu > Preferences > Openbox Configuration Manager ....then click on 'Desktops' and select the number of desktops you require.

If you have not already added the Desktop Pager thing to the LXDE panel, you can right-click on the panel and select 'Add/Remove Panel items', then click on 'Add', find the Desktop Pager in the list, then click on 'Add' to add it to the panel.

It should appear at the bottom of the list of items in the panel, and on the panel itself at the extreme right hand end.

Click on 'Up' or 'Down' on the side of the list to move it where you want to.
Adding a spacer might help it look better, your choice.

You should now be able to switch between desktops using the applet or Ctrl-Alt-arrow keys.

Hope it works for you!


This is in addition to Ben Simmons's answer (dont have prev to post comment yet).

I'm using Debian Jessie, RasPi3. Desktop Preferences in Preferences is hidden by default. So, changing it (Show menu..) by right-clicking on the desktop you wont be able to come back to the right-click menus.

In preference, there is Main Menu Editor use that to have Desktop Preference visible so you can change back to default right-click menus.


Or you can use middle-click on your desktop to bring up a menu for managing desktop...

  • For the x86 Pixel distro, this answer was spot on and worked perfectly.
    – Ron K.
    Oct 25, 2018 at 15:47

I clicked on Menu, then Preferences, then Desktop Preferences, then clicked on the "Advanced" tab, then I clicked the checkbox beside "Show menus provided by window managers when desktop is clicked", then right clicked on the desktop, went to "Desktops" and clicked on "Add new desktop". It even lets me switch workspaces by putting your mouse on "Desktop 2" (or whatever desktop you want) and clicking "Go there..."!

  • 1
    Is this for the LXDE, or some other desktop environment? Feb 6, 2016 at 4:08

Not the answer you're looking for? Browse other questions tagged or ask your own question.