0

My laptop uses wifi, and Pi is connected to router via cable. With the dynamic IP, it worked well with Putty on my windows 7.

Then trouble came after I changed the /etc/network/interfaces on putty to obtain a static IP. Now I cannot "talk" to my Pi, because every time I start a new session on putty with the new static IP, trying to log in my Pi, putty tells me the error: connection timed out.

Now I even cannot find the dynamic IP on my routers webpage...what can I do to get everything go back to the beginning... I miss dynamic IP. Any one could help?

1
  • Word to the wise: Next time you have things working well, use Win32DiskImager to make an image file of the SD Card so you can always revert to a known, good state.
    – SDsolar
    Mar 28 '17 at 6:20
1

This applies to Raspbian Wheezy prior to 2015-05-05 for later (and Jessie) See How do I set up networking/WiFi/Static IP

The default settings in /etc/network/interfaces should be something like

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
auto wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

iface default inet dhcp

See https://raspberrypi.stackexchange.com/a/29806/8697

NOTE It is standard practice on Linux to make a copy of any system file before modifying it.

1
  • 1
    add NOTE: it should be a standard practice not only on Linux!!! ;-) May 2 '15 at 10:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.