1

I'm trying to program the Raspberry Pi 2 with Visual Studio 2015RC and Windows 10 Insider Preview (not the home Edition but a clean install). I'm following the steps described here.

I'm not able to deploy the app on the rpi. This is probarly because the Windows IoT Core Wachter is not running. Wen double click the executable the User Interface does not start (no screen but only a circle icon for a few seconds).

I tryed so far:

  • Running WindowsIoTCoreWatcher.exe. asadmin
  • Running WindowsIoTCoreWatcher.exe as win8 compatibility
  • Reinstal

Do you have the same problem or do you have any suggestions then please let me know.

1

You don't need the WindowsIoTCoreWatcher (and you can even connect from Windows 8.1) to deploy your .NET project on the Raspberry. Simply make sure that ...

  • the raspberry is accessible from your machine, simple method is calling the webinterface at (assuming default machine name): http://minwinpc/
  • the remote debugger process is up and running. You can check in the web interface under "processes": there should be at least one (usually two) instances of the "MSVSMON.EXE". If not, restart the device or issue that command on a remote PowerShell session: "schtasks /run /tn StartMsvsmon"
  • "ARM" is selected as a platform in Visual Studio.
  • "Target Device" is set to "Remote Machine".
  • "Remote Machine" matches the machine name (again, "minwinpc" by default).
  • "Use authentication" is unchecked.

Press F5 in Visual Studio to deploy the Universal App on the Raspberry.

0

WindowsIoTCoreWatcher also failed for me for some reason (it reported several exceptions in the Windows Application Log), but I am still able to deploy/debug my projects.

In Visual Studio command bar set solution configuration to "Debug" and solution platform to "ARM". Next to the debug-icon there should be a small dropdown , open it up and choose "Remote Platform". In the dialog that appears you manually enter your raspberrys IP address, and set authentication mode to "none".

That should be it. Now just press F5.

0

WindowsIoTCoreWatcher is not neccessary for deploying on the RPi2, like Petter Labraten wrote, you should be able to remote debug and deploy, also publish ...

I also found this site: http://makezine.com/2015/04/30/windows-10-iot-core-raspberry-pi-2/

Good luck

-1

Eric L Winkler@msdn posted a workaround

  • 2
    If possible the essential parts of the answer should be posted here. – Ghanima May 6 '15 at 19:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.