10

I have Raspberry Pi B+ (version 1)

I have been googling and trying tutorials and suggestions for 3 hours or so, and I cannot for the life me get chromium that works with the chrome web store ( I think I need version 32+ of which the default wheezy is version 22)

I upgraded raspbian from wheezy to jessie in hopes that the version 42 (per https://www.raspberrypi.org/forums/viewtopic.php?t=109309&p=751381) would install, but apt-get install chromium or apt-get install chromium-browser returns "has no installation candidate" even though my sources.list has

deb http://mirrordirector.raspbian.org/raspbian/ jessie main contrib non-free rpi

It seems the binaries don't exist in the repo?

I don't need raspbian OS, I just need something that can run chrome/chromium and can use extensions (specifically chromecast)

  • Have you tried updating your package lists with sudo apt-get update before you install? – Theoremiser May 24 '15 at 18:45
5
+100

Short answer

There is currently no easy way to get a recent Chromium build on the rpib+.

Options

If you just want chromecast you could try some projects that don't use Chromium because the rpib+ is RAM limited (limiting Chromium functionality) and has a less popular CPU architecture (limiting your install options).

If you really want a recent version of Chromium you need to find a package compiled for your CPU architecture or build it yourself. Note that Chromium builds often lack a lot of features available in Google Chrome (webRTC, pdf viewing, etc).

It appears the distributions of popular branches of linux available for the rpib+ do not have what you are looking for, but you can check all the options here.

Raspbian/Debian

Looking at the URL in

cat /etc/apt/sources.list

You can see that the official OS (raspbian) for the rpi currently has 3 versions:

  • debian 7 wheezy
  • debian 8 jessie
  • debian 9 stretch

apt will tell you where in the repository the files are

apt-cache show chromium | grep Filename

allowing you to see what Chromium versions are available Though it looks like only v22 is available (looks like v42 for the rpi2).

Pidora/Fedora

Fedora does not include Chromium in the core repositories and neither does Pidora.

Arch

Arch Linux ARM only has Chromium builds for ARMv7 not ARMv6.

Raspberry Pi 2

The Raspberry Pi 2 has a more common CPU architecture (ARMv7) And you can get more recent builds from Ubuntu.

Build it yourself

Trying to build it yourself will use up all your RAM and crash your raspberrypi (256MB) but this is the method you could use in qemu or adapt to cross compile. Also note that chromium may require patches to compile and run on the raspberrypi:

mkdir /opt/chromium
cd /opt/chromium
#tmux new -s chromium
git clone --depth 1 https://chromium.googlesource.com/chromium/tools/depot_tools.git
export PATH=$PATH:/opt/chromium/depot_tools
nice fetch --nohooks --no-history chromium
./build/install-build-deps.sh
gclient runhooks
./build/gyp_chromium -Dcomponent=shared_library -Dfastbuild=1
nice ninja -C out/Release chrome
#echo out/Debug/chrome
  • I tried sudo dpkg -i chromium-browser_37.0.2062.120-0ubuntu0.12.04.1~pkg917_armhf.deb but getting error due to the libc6.so.6 version. How did you resolve that? THE ERROR: dpkg: dependency problems prevent configuration of chromium-browser: chromium-browser depends on libc6 (>= 2.15-0ubuntu8); however: Version of libc6:armhf on system is 2.13-38+rpi2+deb7u8. chromium-browser depends on chromium-codecs-ffmpeg-extra (>= 0.6) | chromium-codecs-ffmpeg (>= 0.6); however: Package chromium-codecs-ffmpeg-extra is not installed. Package chromium-codecs-ffmpeg is not installed. – zabumba May 13 '15 at 22:09
  • 1
    Version 37 requires libc6 (>= 2.15 and latest Raspbian provides only with 2.13. I can't see how you could possibly assert that Version 37 for armhf you pointed at, only you have a special hack – zabumba May 13 '15 at 22:18
  • @joelmaranhao it's easyer if you just install Ubuntu – user1133275 May 13 '15 at 23:35
  • The source code for Chromium is listed here: chromium.org/developers/how-tos/get-the-code . You can use this to build your own ARMv6 version. Says it's 22GB(!!!!) so make sure you have that kind of space :) – Phil B. May 21 '15 at 17:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.