1

I installed tightvncserver on my Pi

sudo apt-get install tightvncserver 

Now to run tightvnc server I do

tightvncserver

I get

New 'X' desktop is raspberrypi:7

Starting applications specified in /home/pi/.vnc/xstartup

Now from windows 7, I open TightVNC viewer. I put pi's IP address in Remote host box. enter image description here

I click on connect. I get.

enter image description here

Now what password is being prompted here? I never entered any password? I tried raspberry pi's password, blank password but both failed. What do I have to enter here. Did I miss any steps?

  • I am pretty sure the default is no password, just press OK – rob May 6 '15 at 11:32
  • tried it not working – Coderaemon May 6 '15 at 11:33
  • 1
    DId you run tightvncserver on the Pi? It prompts you to enter a password. – joan May 6 '15 at 12:34
  • it didn't prompt. I had to set it by running vncpasswd. After that it worked fine. – Coderaemon May 7 '15 at 6:54
2

You have to set password for VNC. Type vncpasswd in tight vnc server's terminal (i.e raspberry). Give a password and then try to login your pi.

  • Thanks. Missed the setting of password part. Are there any settings that I have to do when I run the tightvncserver? – Coderaemon May 7 '15 at 6:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.