1

Having some problems trying to install flexget. I get the following error when I run the command:

pi@rpi:~$ sudo pip install flexget

Requirement already satisfied (use --upgrade to upgrade): flexget in /usr/local/lib/python2.7/dist-packages
Downloading/unpacking FeedParser>=5.1.3 (from flexget)
  Cannot fetch index base URL http://pypi.python.org/simple/
  Could not find any downloads that satisfy the requirement FeedParser>=5.1.3 (from flexget)
No distributions at all found for FeedParser>=5.1.3 (from flexget)
Storing complete log in /root/.pip/pip.log

Log:

Exception information:
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/pip-1.2.1-py2.7.egg/pip/basecommand.py", line 107, in main
    status = self.run(options, args)
  File "/usr/local/lib/python2.7/dist-packages/pip-1.2.1-py2.7.egg/pip/commands/install.py", line 256, in run
    requirement_set.prepare_files(finder, force_root_egg_info=self.bundle, bundle=self.bundle)
  File "/usr/local/lib/python2.7/dist-packages/pip-1.2.1-py2.7.egg/pip/req.py", line 1011, in prepare_files
    url = finder.find_requirement(req_to_install, upgrade=self.upgrade)
  File "/usr/local/lib/python2.7/dist-packages/pip-1.2.1-py2.7.egg/pip/index.py", line 157, in find_requirement
    raise DistributionNotFound('No distributions at all found for %s' % req)
DistributionNotFound: No distributions at all found for FeedParser>=5.1.3 (from flexget)

Anyone have any ideas why this is happening?

0

Try install feedparser manually with:

pip install feedparser

I also had to do this for functools32. In addition, running pip install flexget failed a couple of times before it managed to install it successfully.

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.