4

This is kinda weird problem. I used Raspberry Pi A+ for my small projects. I did all the programming using a USB WiFi dongle via SSH. It all went happy and fine until one fine day the dongle stopped blinking (which indicates, no activity. Normally, it has a green LED which blinks when the dongle is working properly). I plugged that dongle on my desktop PC and it worked there. I tried using a different dongle which didn't work on my Raspberry Pi but was working fine on my PC. I even did lsusb test, which couldn't detect my dongle (earlier it showed 'Realtek' for my dongle). I got the verbose output and found that USB current was 0mA.

I plugged a USB flash drive in my RPi. It turned on, but wasn't recognized by the RPi. It indicated that the power lines were fine.

I had a doubt that something was wrong with the USB port on my RPi. I removed the dongle, grabbed my multimeter and did some continuity test. I found that both the USB data lines of the RPi were shorted and grounded. I thought some dust and moisture might have stuck inside and shorted them all to the ground. I dried and blew warm air, cleaned the contacts, yet it was the same. I had a spare USB female port. So, I desoldered the original port and replaced it with the one I had. I even previously checked that the data lines of the new one were not shorted. Yet, the problem reproduced.

I'm still dumbfounded and don't know what's wrong with the USB. I surely checked all the test points and circuit lines and couldn't find anything shorted.

Anybody knows what could be the problem?

  • The first order of business would be to execute something like lsusb -t on the RPi with something plugged into the USB port in order to see what the system sees. – WineSoaked Aug 9 '15 at 23:33
  • This is another article to read up on USB troubleshooting on the RPi: raspberrypi.org/forums/viewtopic.php?f=28&t=53832 – WineSoaked Aug 9 '15 at 23:35
-3

Your adapter can be the matter. I had the same with a sound card, buy an active hub or a better adapter.

  • Thanks for the answer, but I checked the adapter also. It's working fine. I mentioned that I traced the circuit lines and found that something was problematic at the SoC. – Tejas Jadhav Aug 25 '15 at 12:04
  • How does an active hub help a short circuit? – Steve Robillard Aug 30 '15 at 0:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.