I used the search and I posted on this post, but it was deleted.

I have the following error on boot:

***Error in check_disks:could not repair filesystem, dropping to debug shell, try to run 'fsck' manually:***
### Starting debugging shell... Type exit to quit ###
Sh: can't access tty; job control turned off

On the console, you can read a message that recommend to use fsck command to fix it on manual mode.

# fsck -fy /dev/mmcblk0p2 
# reboot

Now, it's when I have the problem, I put that commnad on console but it show me the following error message:

fsck.ext2: Attend to read bloack from filesystem resulted 
in short read while trying to open /dev/mmcblk0p2

Could this be a zero-length partition ?

Any suggestion ?

>> EDIT:

After few time, I decided to replace sd card. Zero problems now.

  • The partition table is corrupted. There are ways to try and fix that (which do not guarantee the partitions will be usable) but it would be easier to just create the card from scratch again. – goldilocks May 11 '15 at 15:19
  • 1
    If you haven't seen it, you may want to look at the new answer I added to the post you originally commented on, regarding why the corruption may be happening: raspberrypi.stackexchange.com/a/31391/5538 – goldilocks May 11 '15 at 15:21
  • I recently tried openelec, and got the same error. Mine came from first trying to write with dd using bs=1024k. Dropping it to bs=512k resolved it for me. – wahoozie May 11 '15 at 23:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.