1

I have a RasperryPi model B (512Mo RAM) and it worked well for 1 year. Several weeks ago I started having problems and I thought it could be the SD card (I sometimes halt it just unplugging the USB). I finally took some time to verify the SD card which seems ok (fsck) so I reinstalled a Raspbian Wheezy image on it.

Now I'm trying to connect to it and can't login. I have no keyboard or screen, I'm using a USB-GPIO connector and minicom on my Debian laptop. I see that the boot happens and it stops at the "login:" prompt which is normal, but I can't type anything, nothing seems to appear on the terminal.

I also tried to access by ssh but I can't. I see that it got an IP from my router but I can't ping or ssh it.

I think it is frozen but a quick check of /var/log/{messages,syslog,debug} shows nothing significant.

Do you have any idea of what the problem can be? Do you know how I can check the hardware part of the Rpi? How can I debug this problem?

Thanks

0

You should try with a normal USB keyboard and mouse (as in, plugging them in and typing). Otherwise, you can try to ref lash the SD Card. That often solves this kind of problem (I had a problem with boot loader, so I ref lashed the SD and works perfectly!).

  • 1
    In fact I ABSOLUTELY need a screen and keyboard to do the first boot config of Raspbian. I had totally forgot this fact. I would like to have a completely ready image of Debian for Rpi. – daks May 12 '15 at 18:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.