1

This is weird. Raspberry Pi wont boot (red led is glowing) using SD card which image is written using dd on Ubuntu laptop, while it will boot if same SD card is written using very same image file on Windows 7 laptop. It happened to me a year ago and yesterday again. Very frustrating... I could not find any solution on internet. Can someone shade some light? Cheers!

What I'm asking is can someone clarify possible causes Raspbian image written to SD using Ubuntu dd tool cannot boot while when same SD card is written using ImageWriter on Windows 7 Raspberry Pi can boot from it?

closed as unclear what you're asking by goldilocks May 13 '15 at 11:54

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Several possibilities. 1) Ubuntu copy bytes is broken, 2) you gave the wrong command, 3) the Ubuntu SD card reader hardware is broken. – joan May 13 '15 at 8:43
  • thanks for fast response :) can you elaborate your answer under bullets 1 and 3: 1) what is ubuntu copy byte and how this issue would manifest other then case I described? 3) card reader hardware seems to operate fine in all other scenarios – soiiid1953 May 13 '15 at 8:47
  • 1
    it might help, if you would add the complete dd command that you have used to write the SD card – Pascal Rosin May 13 '15 at 10:56
  • Problems of the sort, "I put a potato in the microwave, but it did not cook it!" imply either the microwave is broken or you are not using it properly, and have no possible anwser beyond various random musings -- e.g., it could be EM interference. It could be some kind of malware on the Ubuntu system. The possibilities are endless. – goldilocks May 13 '15 at 11:57
  • I checked several sites for "dd" command howto before I searched for help here, one of them is: elinux.org/… I unmount both partitions (/dev/sdb1 and /dev/sdb2) and after that I applied this "dd" command dd if=~/2012-12-16-wheezy-raspbian.img of=/dev/sdb after which I run sync and ejected drive in unity. – soiiid1953 May 13 '15 at 12:41
2

In one comment in this post

I recently tried openelec, and got the same error. Mine came from first trying to write with dd using bs=1024k. Dropping it to bs=512k resolved it for me.

Try to drop bs parameter.

  • this looks promising, but can someone explain background, why reducing bs parameter would fix this issue? is it something with card reader performances? what is standard value for Windows (imagewriter) because it works under windows just fine... Many sites on internet advise this parameter to be increased to 4M (bs=4M) in case when Linux is used to write raspberry image to SD card... – soiiid1953 May 13 '15 at 12:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.