when I enter nslookup in my macbooks terminal, the output is:


Name:   raspberrypi.fritz.box
Name:   raspberrypi.fritz.box
Address: is the static ip I gave to my raspberry through the /etc/network/interfaces.

My etc/hosts file look like this       localhost
::1             localhost ip6-localhost ip6-loopback
fe00::0         ip6-localnet
ff00::0         ip6-mcastprefix
ff02::1         ip6-allnodes
ff02::2         ip6-allrouters       raspberrypi

Where does the come from?

  • Was this either a WiFi address or more likely the DHCP address assigned before you set the static IP (and cached either by your macbook or local router) ? – Steve Robillard May 14 '15 at 12:36
  • @SteveRobillard Im not sure. currently my raspberry is connected using ethernet. before that, it was connected via wifi but with the same static ip. maybe before setting the static ip the .32 ip could be the raspberrys ip. is it possible to reset the cache? I already did sudo discoveryutil mdnsflushcache and sudo discoveryutil udnsflushcaches but that did not help – user30851 May 14 '15 at 12:38
  • 1
    Are you having issues because of this? If the rPi is properly connected and reachable on the x.x.x.200 IP, you should be fine ... the other IP will probably clear in due time. – Phil B. May 14 '15 at 13:07
  • 3
    @goldilocks I think this question is not off-topic and related to Raspbian 2015-05-05 image. I am also stucked here, why DHCP is also assigning different IP even if I have defined one in /etc/network/interfaces. Please open this thread. – Anand Kumar Jul 24 '15 at 5:47
  • 1
    @goldilocks as Anand Kumar has said, this is a specific Raspbian error, described also here: raspberrypi.org/forums/viewtopic.php?f=66&t=111887 it is a bug in the Raspbian package and will contradict all "basic network configuration" topics, since this is about resolvconf not honoring static IP adresses and always using the DHCP. – chiborg Sep 8 '15 at 21:23

what does ip addr show eth0 give as output on the rPi? This is useful to determine where the problem lies:

  1. Does your Pi have 2 IPs? (likely not based on what you showed from /etc/network/interfaces but worth checking)
  2. Is your network router caching a DNS entry for your raspberrypi.fritz.box name? You can check this from the admin settings on the router user interface typically.
  3. Is your Macbook caching the old entry? Flushing the DNS cache would help here - but it won't help if (as per 2. above) the router continues to broadcast 2 DNS entries.

Once you have isolated where the problem is (Pi, router, Mac), you can troubleshoot the specific problem.


Check /etc/network/interfaces to see if there is additional thing written. It usually consists of loopback and eth0.

Not the answer you're looking for? Browse other questions tagged or ask your own question.