0

I have recently been having a problem where I leave my raspberry pi on connected to the internet as I am running an a apache server on it and when I come back to the Raspberry Pi about a day later the dongle isn't flashing blue like it usually does. I go to the wpa_gui and it says as the status 'Could not get status from spa_supplicant'. I tried taking out the dongle half way and then pushing it back in. This seems to get it working again but I had it working before where I could just leave it and it would stay connected to the internet. Does anyone have any ideas what I could do to stop it disconnecting?

9
  • 1
    Have you checked the logs? /var/log/udev and /var/log/dmesg might be good places to start.
    – Jacobm001
    Commented May 14, 2015 at 22:03
  • what do i look for inside the dmesg? Commented May 14, 2015 at 22:07
  • I have changed the usb ports of the dongle to see what happens because before it all started to happen I seem to remember that i had my dongle on the bottom usb port and the usb hub on the top one. Commented May 14, 2015 at 22:19
  • It might also me a problem with your router. You should look into your router settings and see if it refreshes the router on a 24 hr basis for example.
    – NULL
    Commented May 15, 2015 at 1:32
  • 1
    great you got it sorted. Please add your solution as an answer with as much details regarding the driver versions and how you identified/updated them when you get the chance.
    – rob
    Commented May 15, 2015 at 7:22

1 Answer 1

1

Maybe your wifi dongle entered in power saving mode, toit, you have to add "wireless-power off" in your "interfaces" file

1/ Type

sudo nano /etc/network/interfaces

2/ Add at the end of file

wireless-power off

3/ Reboot by typing :

sudo reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.