I setup my raspberry PI with a SAMBA share loosely following the instructions here. After setting up everything, installing SAMBA, NTFS, and all, I was able to use everything last night with no problems. This morning, I woke up and all the shares still existed, but no files were found and my Windows box couldn't open the shares.

Using ls on the mounted folder, showed no files, so I rebooted, tried again with the same result. Using sudo ls still showed no files. I was able to create a test file on the USB HD, and that worked well.

Thinking my files were gone, I plugged the USB HD into my Windows box, but all the original files were still there, and I couldn't see the test file I added via my Pi.

Why does my PI show different files on the same USB HD than my Windows machine does?

Mount Output

/dev/root on / type ext4 (rw,noatime,data=ordered)
devtmpfs on /dev type devtmpfs (rw,relatime,size=218636k,nr_inodes=54659,mode=755)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=44584k,mode=755)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /run/shm type tmpfs (rw,nosuid,nodev,noexec,relatime,size=89160k)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
/dev/mmcblk0p1 on /boot type vfat (rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=ascii,shortname=mixed,errors=remount-ro)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
/dev/sda1 on /media/USBHDD1 type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096)

1 Answer 1


Is the USB hdd actually mounted? Type mount and see what it says.

If it's not mounted, you will see an empty "disk", because you're looking at the mount point which is an empty directory.

Another clue will be that the file you created is still visible even when the hdd is unplugged.

  • I've added the output of Mount to my question.
    – lfrandom
    May 18, 2015 at 21:47
  • This turned out to be the answer, I used umount and mount and then was able to find it. The weird thing is that mount did show the device.
    – lfrandom
    May 18, 2015 at 21:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.