1

i do not seem having luck with my raspberry pi 2. So basicly i have no possibility to connect my rasppi to a monitor or tv, so there is no way i can find out whats wrong. Next thing is that i also cannot connect it to a router with dhcp, i don't have one. So I want a static ip configuration. What i did on the old raspbianversion from february was mounting the sd-card, configuring the interfaces file, and then it worked fine. I could ping the pi2 and connect to it with ssh. BUT... for some reason it was half broken. I could not use crucial binaries like dpkg, apt-get, scp. So basicly i hoped the problems would get solved with a new release of raspbian. But doing the same thing with the new version of raspbian does not work. It isn't even pingable. I don't know wheater it does not boot or it is a problem with the network. I tried it on 2 different sd-cards, so it's probably not a sd-card issue. Here's my interfaces:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.178.42
netmask 255.255.255.0
broadcast 192.168.178.255

Any ideas what i could try out?

  • If you can write to /etc/network/interfaces that sort of implies you have a Linux machine. If that's the case you could run a DHCP server (e.g. dnsmasq) on the Linux machine. What is the IP address of the machine you connect to the Pi via ethernet? – joan May 17 '15 at 13:28
2

You are not defining a gateway in your setup, which means the Pi has no way to get outside of your network. You say you have no router with DHCP, but I assume you do have a modem connecting you to the Internet, and the network other devices in your home use is the 192.168.178.x network (if you just made up these numbers with no other device providing the same network of course nothing will work). The modem will have an IP address, likely 192.168.178.1 or 192.168.178.254 and should be the gateway, so you could just add that IP as the gateway.

For the "not being pingable" part of your problem, make sure that:

  1. You have indeed edited the right file (/etc/network/interfaces)
  2. The permissions and ownership of this file are correct
  3. The IP addresses are correct

For this community to do more troubleshooting you would need to provide more details on how you are connecting to the rPi, e.g. What it is connected to, the type of computer you are using to connect, the network settings of this computer, the OS version, and how you are connecting to the outside world. The resolution to your problem varies based on all these factors.

  • I'm not defining a gateway, because i don't need one. I just want to direcly connect to my rasppi through a cable, i don't want to be online with it. So basicly i give this computer the ipadress 192.168.178.40 and my rasppi gets 192.168.178.42. It looks like the boot isn't successful: There is no /var/log/syslog and /var/log/dmesg is also empty... I fear either my raspberry is broken or both of my microsd cards. – mic May 17 '15 at 15:37
  • If you could add this compu setup info into your post (or let me know if you don't have edit priviliges and I will do the edit for you) that would help. Anyways, the "online" part is needed to make apt-get etc. work, (where else would it get the content from - do you have a local repository on your computer?). From what you are describing here you are either trying to create a 2-point network between your computer and your Pi, or you are trying to do Internet Connection Sharing from your computer, but haven't configged your compu to do this sharing correctly. – Phil B. May 17 '15 at 15:48
1

Any ideas what i could try out?

  1. Monitor the attempted connection with wireshark to confirm that the pi is unresponsive.

  2. Take the card out and look in /var/log/syslog. By default on Raspbian wheezy all system messages go there. Unfortunately the timestamps will be wrong if the pi has not been able to connect to an NTP server, but you can at least tell whether it is even booting up properly and if so, what has gone wrong with networking. You can edit that file, so to make it clear when the next boot messages start, add a few blank lines and something like "NEW MESSAGES START HERE". The logger will not delete that when you put it back in and boot up.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.