2

First of all, I'm not sure if I should be asking this here, or on stackoverflow. But, here will be my first shot, if it's not the right place, just tell me and I'll move the question elsewhere.

Ok, now the the problem itself.

I've developed a Qt5 app, and I'd like to see it running on the pi2. First of all I noticed that Ubuntu MATE 15.04 comes with Qt 4.8 by default, and it have qt5-base and qmake5 on it's apt-get repository. But when I tried to use it, I've ran into some dependency problems, and the qt5 ended up not beign installed at all.

I've found this tutorial to compile qt5 from scratch on rasp1 with raspbian, and this one to do the same on rasp2, but that can take a long while, and lots of things can go wrong, so if it's possible to just do an apt-get it'll be A LOT easier for me (and anyone else who might step into this same problem).

And I would also want to know if after it's compiled, if my program will be able to play hardware accelerated videos using QMediaPlayer.

P.S.: Yes, I've bought the licenses to decode AVC-1 and MPEG in the hardware.

Edit: I've found this question talking about an Hardware accelerated VLC, it's slightly related to my problem, I guess.

Edit 2: Which packages would be enough to compile a Qt project that needs only the QtCore/QtBase and QtMultimedia?

Edit 3: I've followed the instructions on the answers and comments, using the Raspbian Jessie repository to install qt5. I've ran:

sudo apt-get update
sudo apt-get install qt5-default libqt5multimedia5 libqt5multimedia5-plugins libqt5multimediawidgets5

And the package manager installed lots of dependencies along.

After that, I've tried to run qtconfig but I got this error:

qtconfig: could not exec '/usr/lib/arm-linux-gnueabihf/qt5/bin/qtconfig': No such file or directory

And after that, I tried to run qmake on my project, and I got:

Project ERROR: Unknown module(s) in QT: multimediawidgets multimedia

Well, I feel a little lost here...

Edit 4: I've also found this question here. I guess this guy is having a similar problem.

Edit 5: Yupp, I'm not the only one with this problem. As you can see here.

2

Raspbian jessie appears to have qt5 in the repository. If you're still on Wheezy, you can upgrade it through this tutorial.

$ cat /etc/os-release  
PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"
NAME="Raspbian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"

A trimmed apt-cache search

$ apt-cache search qt5
...
libqt5gui5 - Qt 5 GUI module
libqt5help5 - Qt 5 help module
libqt5keychain0 - Qt API to store passwords (QT5 version)
libqt5multimedia5 - Qt 5 Multimedia module
libqt5multimedia5-plugins - Qt 5 Multimedia module plugins
libqt5multimediaquick-p5 - Qt 5 Multimedia Quick module
libqt5multimediawidgets5 - Qt 5 Multimedia Widgets module
libqt5network5 - Qt 5 network module
libqt5nfc5 - Qt Connectivity NFC module
libqt5opengl5 - Qt 5 OpenGL module
libqt5opengl5-dev - Qt 5 OpenGL library development files
libqt5positioning5 - Qt Positioning module
libqt5positioning5-plugins - Qt Positioning module - position plugins
libqt5printsupport5 - Qt 5 print support module
libqt5qml5 - Qt 5 QML module
libqt5quick5 - Qt 5 Quick library
libqt5quickparticles5 - Qt 5 Quick particules module
libqt5quicktest5 - Qt 5 Quick Test library
libqt5quickwidgets5 - Qt 5 Quick Widgets library
libqt5scintilla2-11 - Qt5 port of the Scintilla source code editing widget
libqt5scintilla2-11-dbg - Qt5 port of the Scintilla source code editing widget (debug)
libqt5scintilla2-designer - Qt5 Designer plugin for QScintilla 2
libqt5scintilla2-designer-dbg - Qt5 Designer plugin for QScintilla 2 (debug)
libqt5scintilla2-dev - Scintilla source code editing widget for Qt5, development files
libqt5scintilla2-l10n - Scintilla source code editing widget for Qt5, translation files
libqt5script5 - Qt 5 script module
libqt5scripttools5 - Qt 5 script tools module
libqt5sensors5 - Qt Sensors module
libqt5sensors5-dev - Qt 5 Sensors development files
libqt5serialport5 - Qt 5 serial port support
libqt5serialport5-dev - Qt 5 serial port development files
libqt5sql5 - Qt 5 SQL module
libqt5sql5-mysql - Qt 5 MySQL database driver
libqt5sql5-odbc - Qt 5 ODBC database driver
libqt5sql5-psql - Qt 5 PostgreSQL database driver
libqt5sql5-sqlite - Qt 5 SQLite 3 database driver
libqt5sql5-tds - Qt 5 FreeTDS database driver
libqt5svg5 - Qt 5 SVG module
libqt5svg5-dev - Qt 5 SVG module development files
libqt5svg5-private-dev - Qt 5 SVG module private development files
libqt5test5 - Qt 5 test module
libqt5webkit5 - Web content engine library for Qt
libqt5webkit5-dev - Web content engine library for Qt - development files
libqt5websockets5 - Qt 5 Web Sockets module
libqt5websockets5-dev - Qt 5 Web Sockets module - development files
libqt5widgets5 - Qt 5 widgets module
libqt5x11extras5 - Qt 5 X11 extras
libqt5x11extras5-dev - Qt 5 X11 extras development files
libqt5xml5 - Qt 5 XML module
libqt5xmlpatterns5 - Qt 5 XML patterns module
libqt5xmlpatterns5-dev - Qt 5 XML patterns development files
libqt5xmlpatterns5-private-dev - Qt 5 XML patterns private development files
...
  • 1
    Is this the latest release? If it's not, where can I get it? – Mauker May 18 '15 at 13:43
  • I'm not sure if Raspbian defaults to wheezy or jessie. I just downloaded the latest version (wheezy at the time) and changed wheezy to jessie in the source lists. Search for update to jessie. – joan May 18 '15 at 13:46
  • 1
  • Interesting idea. I'll try to use the qt5 from Jessie without upgrading. If I'm unsuccessful, I'll try to upgrade it. – Mauker May 18 '15 at 14:18
  • It seems to have installed, I can find the qmake but... some stuff are not working that well. Like qtconfig, it throws an error like: qtconfig: could not exec '/usr/lib/arm-linux-gnueabihf/qt5/bin/qtconfig': No such file or directory and even if I've installed libqt5multimedia5 libqt5multimediawidgets5 libqt5multimedia5-plugins, when I try to run qmake on my project I get: Project ERROR: Unknown module(s) in QT: multimediawidgets multimedia – Mauker May 18 '15 at 20:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.