2

My pi's wireless network go off after 12 hours. I have a cron job which sends some data to a web address each 15 minutes, so the internet connection is always active for my Raspberry pi, and logically it should not go to sleep or idle ever.

I have checked that the power management is already off. I checked it using iwconfig command.

But I'm still facing the problem of getting off on the pi wifi dongle.

Any Suggestions? Thank you in Advance.

  • I have a similar problem in a smaller timeframe. I think in my case the WiFi dongle loses power at some point and the pi fails to reconnect. – Minix May 18 '15 at 18:07
  • This seems to be a common problem; I think it is some combination of power and driver issues. Unfortunately you can't do much about those, but as a hack solution you could try this: raspberrypi.stackexchange.com/a/5121/5538 – goldilocks May 18 '15 at 18:52
  • Everytime exactly after 12 hours? – Loko May 19 '15 at 11:12
  • @Loko its not 12hours exactly. Sometimes before and sometimes later but it does. yesterday it was alive and send info to website for 9 hours. At start i have put to code to down and then the wifi if its not connected to internet. this code works well if we turn off the router and then again turn on. The pi automatically connects with the router again. but the same code doesn't work for this dead sleep. I have also noticed this issue is only happening to all lastest model pis. I never found this problem with the old pi which has 26 pins. – vuimran May 20 '15 at 8:51
1

Did you turn off the idle state of your WLAN dongle? I believe there was an option for the /etc/network/interfaces.

Or another suggestion is: is your PI running headless? In my case, my whole Pi went into idle mode because of the HDMI connection and the associated configuration.

0

It takes alot of time to figure the TRUE SOLUTION out : upgrade your kernel. I'm making my own Linux distro now because of too many bugs in Rasbpian and Ubuntu for RPi's... The problem you've mentioned is "gone with the kernel". Use an official Git from kernel.org, I do recommend you start with a stable one.

0

One other theoretical possibility - what is the lease time on the IP address from the router and are you getting a stable IP address all the time - if you have a home LAN arrangement and that is doing DHCP for you I have had odd networking problems when the lease runs out - which could easily be set to 12 hours or a day AND THE NEW ADDRESS clashes with something with a STATIC IP address on the same network.

People often set up units as servers with static addresses manually but forget to ensure that those addresses do not clash with the range used by their DHCP server - often they could be better off ensuring that their DHCP server assigns a static (a.k.a. reserved) IP to their server (which will be keyed to the MAC of the network interface used) and will achieve the same result as setting it up manually, IMHO.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.