In the last month or so, one of my external hard drives has stopped working properly with my Raspberry Pi. It works for a while, then it stops working randomly.

  • I ran ls on the drive's folder and it gives me ls: reading directory .: Input/output error.

  • So I tried dmesg | tail and I got a series of

    Buffer I/O error on dev sda1, logical block XXXXXX [this is different each time], async page read
  • The disk works again if I reboot the Pi (even without physically turning it off and on).

  • I assumed it was a drive failure, so I bought a new one and copied the data across from a backup I have. However, the new one also gives the same error. I then thought it might be the Pi itself (Pi 1 Model B), so I swapped it with another Raspberry Pi I have (swapped the memory cards around). But I still got the same error.

  • I then tried reinstalling Raspbian from scratch and reinstalling all my programs (Transmission, minidlna, Samba) but I still get the problem.
    There is another drive connected (to which I run backups of my computer's HDD and the other disk on the RPi - or I used to until it started playing up) but I've had no problems with it at all.

  • Both drives are powered by their own external power supplies.

I really don't understand why this keeps happening. If it were a hardware problem, the old disk wouldn't work in Windows (which it does, and having checked it with chkdsk it gives no errors) and the new disk should work on the RPi (which it doesn't properly).

Both drives are NTFS and run with ntfs-3g

EDIT: it was, in fact, a hardware problem - I copied the data to another disk before it died

  • The disk is powered using its own power adapter and not via the Pi.
    – ferg92
    Commented May 22, 2015 at 9:20
  • You can copy the broken sd card with a more larger memory card. Maybe it's becasue the storage is full, and the sd card is dead.
    – gogog
    Commented Sep 3, 2022 at 0:34

1 Answer 1


Update: Just found a answer may help , it solved my problem.

Connection problem with usb3 external storage on Linux (UAS driver problem)

Looks like a kernel issue.

I have the same problem here, not Raspbian, a old laptop with archlinux.

I searched a lot, tried every way I can . Now I think it was caused by Hardware or device driver faults, not a software faults.

What does the “I/O error” mean?

What does the “I/O error” mean?
The Input/Output errors mean unexpected, low-level errors. They are caused by hardware errors (disk, RAM, cable, power supply, motherboard, etc), device driver faults, corrupted file system, software fault or incorrect hardware use. 

I found that:

Buffer I/O error on device sda1, logical block …
reset high speed USB device using ehci_hcd and address 17

same with what happened to my computer...

This may help:

What are USB device resets?

The problem could be in marginal voltage (VBUS) supply to the drives, or VBUS glitches, or signal degradation on signal wires. I would try extremely short high-quality certified cables first, and check if the statistics of error changes.

I guess it may caused by something else like usb port poor connection or driver problem, not hard disk.

I didn't find anyone fixed this with software configuration so far.

Maybe you should check you Raspbian not your disk.

That is my assumptions, hope it can help you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.