when running sudo blkid and sudo fdisk -l no usb drive shows.

The output from dmesg however makes it appear that the external hard drive has no issues

[    3.409324] usb 1-1.3: new high-speed USB device number 4 using dwc_otg
[    3.539853] usb 1-1.3: New USB device found, idVendor=1a40, idProduct=0101
[    3.553142] usb 1-1.3: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[    3.565401] usb 1-1.3: Product: USB 2.0 Hub
[    3.573950] hub 1-1.3:1.0: USB hub found
[    3.582583] hub 1-1.3:1.0: 4 ports detected
[    3.829293] usb 1-1.5: new high-speed USB device number 5 using dwc_otg
[    3.949334] usb 1-1.3.1: new high-speed USB device number 6 using dwc_otg
[    4.070208] usb 1-1.3.1: New USB device found, idVendor=1a40, idProduct=0101
[    4.084125] usb 1-1.3.1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[    4.097652] usb 1-1.3.1: Product: USB 2.0 Hub
[    4.110172] hub 1-1.3.1:1.0: USB hub found
[    4.124196] hub 1-1.3.1:1.0: 4 ports detected
[    4.289293] usb 1-1.5: new high-speed USB device number 7 using dwc_otg
[    4.375225] udevd[160]: starting version 175
[    4.410746] usb 1-1.5: New USB device found, idVendor=1058, idProduct=07a8
[    4.435876] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    4.469171] usb 1-1.5: Product: My Passport 07A8
[    4.494288] usb 1-1.5: Manufacturer: Western Digital
[    4.515475] usb 1-1.5: SerialNumber: 5758353145343356434C3834
[    4.550417] usb-storage 1-1.5:1.0: USB Mass Storage device detected
[    4.589716] scsi host0: usb-storage 1-1.5:1.0
[    5.590258] scsi 0:0:0:0: Direct-Access     WD       My Passport 07A8 1042 PQ: 0 ANSI: 6
[    5.642384] sd 0:0:0:0: [sda] Spinning up disk...
[    5.652691] scsi 0:0:0:1: Enclosure         WD       SES Device       1042 PQ: 0 ANSI: 6
[    6.669130] ..
[    8.449797] sd 0:0:0:0: Attached scsi generic sg0 type 0
[    8.460258] scsi 0:0:0:1: Attached scsi generic sg1 type 13
[    8.579095] random: nonblocking pool is initialized

to be more specific, I have a powered usb hub plugged into the pi (and the wall) and a Western Digital 1TB external hard drive plugged into the pi (I can hear it running)

  • Does the hard drive work on other machines?
    – user236012
    May 23, 2015 at 10:10
  • 1) is the powered hub strong enough? I have some 4 port hubs that claim to be powered but really just provide the minimum 500mA to each port, and most external USB HDDs need a bit more than that.
    – Phil B.
    May 23, 2015 at 12:47
  • 2) What is the output of lsusb?
    – Phil B.
    May 23, 2015 at 12:48
  • Just tried this with a Raspberry Pi 2 and a very similar My Passport Ultra 1TB. Plugging the drive into the hub worked no trouble (dmesg shows the all-important "… mounted filesystem with ordered data mode" after the SCSI lines). Plugging the drive directly into the Raspberry Pi 2 spun it up, but it kept trying to remount and locked the system 9. So it's likely a power thing. Use the hub for the drive connection and tell us how you get on.
    – scruss
    May 23, 2015 at 15:37
  • Ok thanks this is all very useful information. I am unfortunately away from my pi until tomorrow, I will let everyone know the details then
    – andykais
    May 24, 2015 at 15:24

1 Answer 1


a Western Digital 1TB external hard drive plugged into the pi

This implies the drive is not plugged into the hub, which is the way you should do this. The pi and the drive are plugged into the hub, and the hub's data cable into the pi.

If the hub is properly regulated (though they often aren't), it will only provide 500 mA to each port, and while that might be enough for a pi, it won't be enough to properly power anything attached directly to it. The drive needs to get its power directly from the hub.

I've color coded the connections below in case this isn't clear. The ethernet cable is irrelevant. Red is for the hub's data cable (there is only one per hub), green is the USB cable from the hub to the drive, yellow is for powering the pi.

enter image description here

lsusb output on that pi looks like this:

Bus 001 Device 005: ID 174c:55aa ASMedia Technology Inc. ASMedia 2105 SATA bridge
Bus 001 Device 004: ID 050d:0237 Belkin Components F5U237 USB 2.0 7-Port Hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Notice the external hub (Belkin) and the external drive, plugged into the hub (ASMedia), are both visible. Again, the power for both the pi and the drive comes from the hub. The data cable is indicated in red. Notice it uses a special port. There is only one of these on the hub.

  • "The pi and the drive are plugged into the hub …": I didn't think this would work, or is it what you're recommending against? I know some hubs have charge-only sockets for which this works fine.
    – scruss
    May 23, 2015 at 15:41
  • @scruss That's what I'm recommending and that's what I do when using an external drive with a model B. You plug the hub into an outlet. You power the pi from the hub (USB -> microUSB). You plug the hard drive into the hub (USB -> USB). The hub has a data port, probably microUSB or similar to prevent confusion with the normal ports, and it came with a cable that plugs into there with normal USB at the other end. You plug that into one of the pi's USB inputs. Any devices on the hub are now accessible on the pi, including the drive. I've added a picture and some details in case this isn't clear.
    – goldilocks
    May 23, 2015 at 16:15
  • Neat! And thanks for the clear pictures. I would have thought that the Raspberry Pi power port would fail enumeration, and (fatally) limit itself to 100 mA
    – scruss
    May 23, 2015 at 17:07
  • I have the HDD connected to the usb hub now, lsusb shows the drive, the output for dmesg is here http://pastebin.com/97gxvejy
    – andykais
    May 26, 2015 at 1:36
  • That "........not responding" thing is unfortunate. It should work; I googled "linux Passport 07A8" and interestingly got more hits of people complaining it worked fine under e.g. OSX and Ubuntu but not Windows. Etc. -- point being it's not probably not a driver problem w/ linux. I'm presuming you have tried it on another computer and it is okay there? If so, try it via the hub on that computer too.
    – goldilocks
    May 26, 2015 at 11:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.