2

I tried to install geany on the raspberry pi type b+ with:

sudo apt-get -f install geany

but we get this error:

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 geany : Depends: geany-common (= 1.22+dfsg-2) but it is not going to
be installed
 pinta : Depends: mono-runtime (>= 2.10.1) but it is not going to be installed
         Depends: libglib2.0-cil (>= 2.12.10-1ubuntu1) but it is not
going to be installed
         Depends: libgtk2.0-cil (>= 2.12.10-1ubuntu1) but it is not
going to be installed
         Depends: libmono-addins-gui0.2-cil (>= 0.6) but it is not
going to be installed
         Depends: libmono-addins0.2-cil (>= 0.6) but it is not going
to be installed
         Depends: libmono-cairo4.0-cil (>= 2.10.1) but it is not going
to be installed
         Depends: libmono-corlib4.0-cil (>= 2.10.1) but it is not
going to be installed
         Depends: libmono-posix4.0-cil (>= 2.10.1) but it is not going
to be installed
         Depends: libmono-sharpzip4.84-cil (>= 1.0) but it is not
going to be installed
         Depends: libmono-system-core4.0-cil (>= 2.10.3) but it is not
going to be installed
         Depends: libmono-system-xml4.0-cil (>= 1.0) but it is not
going to be installed
         Depends: libmono-system4.0-cil (>= 2.10.7) but it is not
going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or
specify a solution).

and we also get it for other programs like java.

what does this mean? how to fix it?

ps. I am totaly new to raspberry pi.

  • 2
    Firstly Do: apt-get -f install; apt-get update; apt-get upgrade – RahulAN May 28 '15 at 7:55
  • 1
    As RahulAN says, try sudo apt-get upgrade then sudo apt-get update and indicate whether that worked or not. – goldilocks May 28 '15 at 7:59
1

As RahulAN and goldilocks suggested: Use sudo apt-get update to update repository first, and then do sudo apt-get upgrade to update package to latest version. After that you can install anything as long it have dependency on repository. You might do sudo apt-get -f install to fix your beforehand software installation before installing another software with apt-get install

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.