4

My wifi adapter worked fine with the Rapsberry pi B but when I update to Raspberry pi2 it doesn't work. I'm using wheezy and when I run lsusb I get:

Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter

but when I hit scan with Wifi-config GUI nothing appears.

  • 1
    Try ip link set wlan0 up first. – goldilocks May 29 '15 at 11:33
0

That adapter requires drivers that are not part of the standard raspibian distribution. If you do ifconfig, does the interface show up? If not, check here for info on getting updated drivers. After you install the driver and reboot, it should show up in ifconfig and iwconfig. You'll need to do this after every firmware update.

  • <this is what a get when i run iwconfig:>/ wlan0 IEEE 802.11bgn ESSID:off/any Mode:Managed Ac Retry short limit:7 RTS thr:off Fragment thr:offcess Point: Not- Power Management:off Associated Tx-Power=20 dBm – ppersia37 May 29 '15 at 9:55
  • but still no luck when i hit scan with wpa-gui – ppersia37 May 29 '15 at 10:04
  • If it shows up in iwconfig the driver is loaded and to some degree working. I have a RT5370 USB adapter, and it works fine, including on a Pi 2 -- the driver is rt2x00usb (you'll see it w/ lsmod | grep rt2), which is included in Raspbian. However, it's not impossible that a bug was introduced in some particular kernel version. – goldilocks May 29 '15 at 11:30
  • lsmod | grep rt2 rt2800usb 17886 0 rt2800lib 71839 1 rt2800usb rt2x00usb 8517 1 rt2800usb rt2x00lib 36704 3 rt2x00usb,rt2800lib,rt2800usb mac80211 479583 3 rt2x00lib,rt2x00usb,rt2800lib cfg80211 386516 2 mac80211,rt2x00lib crc_ccitt 1153 1 rt2800lib – ppersia37 May 29 '15 at 13:11
  • yes i do have the driver but stil not working – ppersia37 May 29 '15 at 13:11
0

On my raspberry-pi2 i had the same problem. In the taskbar it seems that the network connection couldn't established, however after I manually entered my wifi SSID and password to /etc/network/interfaces file it was connecting to the internet. So you may try that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.