I am running a custom version of Raspbian on my B+ with a touchscreen. This OS was customized to work with the WaveShare SpotPear A screen they sell. It is configured to auto login to to the desktop as the pi user. I wan't to disable that so I tried the following:

  • sudo raspi-config; boot to console option
  • Commented out all autologin lines in lightdm.conf
  • Went to /etc/inittab and verified there were no incorrect Entries doing the opposite of this tutorial.
  • Tried to disable lightdm with the command Sudo update-rc.d lightdm disable 2 giving me this error:

    update-rc.d: using dependency based boot sequencing insserv: warning: current start runlevel (s) (3 4 5) of script lightdm 'overrides LSB defaults (2 3 4 5). insserv: warning: current stop runlevel (s) (0 1 2 6) of script lightdm 'overrides LSB defaults (0 1 6).

  • Tried sudo apt-get --purge lightdm gave an error saying stuff depended on it. But things that depended on it could not be uninstalled because it said they already were. So I used aptitude and was able to fix that and finally uninstalled it and rebooted. It brought me back to the desktop again! I checked in the lightdm folder and there wasn't a lightdm.conf file anymore. Just to see what happened I logged off. Which does not show screen but shows the terminal. I proceded to login as pi and type startx. It then showed a message like it had worked talking about who created it etc but did not go to desktop or let me type anything. Ctrl + Alt + Backspace is the only thing that saved me! I then rebooted and it went to the desktop like nothing happened.

Other questions have addressed this question but the answers above worked. I haven't had success with any of these. Does anyone know further configuration possibilities that could fix this issue?

  • Much better +1 is the source of the kernel online if so you could look through t for the changes. second is the screen using lightdm? this may be one of the changes they made. Also, have you contacted the seller? This thread may help github.com/notro/fbtft/issues/215 Commented May 28, 2015 at 22:16
  • I found the answer...by mistake! :-)
    – NULL
    Commented May 29, 2015 at 10:41

1 Answer 1


I found the answer by mistake when I was getting a bash file to run at boot!


To fix this problem:

  • nagivate to /etc/rc.local.
  • In the file, right before exit(0), remove the line containing su -1 pi -c startx where pi is the username being logged in.

The line will most likely have extra commands in it so don't be surprised if it looks a little different. As a precaution it might be best to comment it out and reboot to make sure it works for you instead of deleting the line all together!

  • Wow -- please tell me the SpotPear people did not really put sudo in rc.local. It runs root...
    – goldilocks
    Commented May 29, 2015 at 11:02
  • My bad...it actually starts with su...fixed it.
    – NULL
    Commented May 29, 2015 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.