1

I configured my Raspberry Pi B+ with OSMC to accept incoming connection from outside.

This works fine if I use directly the public IP from ssh command on console, but if I use my No-IP hostname (associated with the corrected IP), the console says "Connection timed out".

Why?
I used also an external port checker with my No-IP hostname and it says that the port is open.

  • When you say "ssh command on console", what do you mean by console? Do you mean from another computer on the Internet? Or do you mean from the console of the Pi. If you're using another computer, does that computer return the public IP of you Pi when you nslookup your no-ip host name? – HeatfanJohn May 29 '15 at 21:52
  • I mean from another computer or smartphone with ssh client. Yes, nslookup return the public IP. – AlexBerry May 30 '15 at 10:54
2

Problem solved. I was connected on the same local network and my pc/smartphone was using local dns to resolve hostname instead of external dns, so using only 3g network, I tried to connect using No-Ip hostname and it worked fine.

  • Glad this worked. You may want to consider setting up bind9 on your RPi and using that for your home's DNS. This way, you can set up a local entry for your NoIP host name and it will work inside and outside the home. Managing an internal DNS server(s) is not without its own headaches, but also comes with unique benefits. – Patrick Tucci Jun 10 '15 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.