2

I have a 3.5in touchscreen attached to the GPIO of my B+. Most windows you can double click the decorations to resize to fit the screen. However, some windows have that feature disabled(at least via the GUI) and are too big to drag. Because of this problem I can't do certain things because I cannot reach the OK button!

So my question is, is there a supported way in python or a bash script I could use to force the window size to be within the limits of the screen? Of is there a setting I am unaware of in the GUI? I cannot find anything on this subject. I would prefer a solution that does not require a new installation(for example wmiface).

3
  • 3
    if all you want to do is hit enter have you tried the enter button? you may need the tab key. Also I believe the resize shortcut is ctrl-z. Expecting a 3.5 inch screen to be as functional as a fullsize monitor may be an unrealistic expectation. – Steve Robillard May 29 '15 at 19:41
  • lol...well for the enter key that does not work because sometimes the dialog box does not have enter as the suggested button if you know what I mean and yeah I have tried tabbing to it but I am trying to find a more practical way. Specifically, I am having a problem with the python IDLE preferences window. I would like to change the font size but am unable to becuase of this. I'll try Ctrl-Z. – NULL May 29 '15 at 19:45
  • Ctrl + z does not work. I don't expect total same functionality but need for windows that I cant re-adjust, tab and enter don't work and ctrl+z doesn't work on. – NULL Jun 5 '15 at 20:13
3

Press and hold left alt key, then you can click and drag windows around from anywhere (as opposed to having to click and hold top bar to move windows)

Now...
I see a lot of folks on a fresh install saying this doesnt work anymore. Keep in mind this is not simply an Rpi feature, it's linux, Xorg to be more specific, and has been around longer than Rpi's have. Needless to say... it still works.

A likely cause, especially to those newer to linux, is your locale and keyboard layout settings. If these setting don't match your situation, you will run into a handful of annoying little problems like this where you press the alt key for example, but the system registers it as some other key. (if you have already checked this and know you're configured properly, the rest if this post won't help you)

A fresh Raspian install locale defaults to the UK with a generic UK keyboard layout. I'm in the US so I'll run through a quick US config, but this should still help those from elsewhere get pointed in the right direction.

Boot up, log in terminal style and type: sudo raspi-config

Navigate to: Internationalisation > Change Locale

Spacebar to uncheck the en_GB.UTF8 option and then down a bit further to select en_US.UTF-8 UTF-8 instead. < ok> and back out to main menu.

This time to: Internationalisation > Change Keyboard Layout

In here you want Generic 104-key PC and then English (US). It will ask you a few additional preferences, you can play it safe go with the defaults if you're a little unsure on these.

Back out, reboot into GUI, left alt + left click and hold anywhere on a window to drag it around.

Somewhat unrelated tip... If you get sick of typing sudo every time you're in the terminal doing root stuff type: sudo -i and hit enter. This will put you in "perma-root mode" for the remainder of that session, or until you exit back out of it.

EDIT: Another instant workaround that might even work with the UK/GB settings is to try right alt. I can't confirm this as I am using one of them little compact wireless keyboards which literally does not have a right alt key, but if you're on a full size it's worth a shot.

1
  • On a mac, use the cmd key instead of alt – Dan B Jul 14 '17 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.