3

I used this hard drive with Raspbmc with no problems, but since I updated to OSMC, this seems to mount the disk as read only. I need to change some permissions and modes and I get this message:

chmod 775 Completed/
chmod: changing permissions of ‘Completed/’: Read-only file system

The drive is in /media and it is automatically mounted by OSMC, I didn't do it manually.

My fstab looks like this:

/dev/mmcblk0p1  /boot    vfat     defaults,noatime    0   0
/dev/mmcblk0p2  /        ext4     defaults,noatime    0   0
  • What is the output of cat /etc/fstab? – Bex Jun 1 '15 at 7:36
  • Is journaling disabled on the HFS+ volume? Linux appears to not natively support read-write to journaled HFS+ volumes, see superuser.com/questions/84446/… – HeatfanJohn Jun 1 '15 at 13:37
  • Thanks, @HeatfanJohn. I solved my problem with your link. What should I do now with my question? Should it be closed as duplicate and linked to that question? – Danowsky Jun 1 '15 at 18:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.