0

I saw this answer for configuring enabling and being able to use audio but was unsuccessful. I want to have audio to my headphones which are plugged into the 3.5mm jack. I have tried:

  • Forcing audio to the headphone Jack
  • Making sure I have alsa-utils installed(I asume I do because aplay does not give errors; in fact it says it is playing the file I give it!)
  • I ran modprobe snd_bcm2835
  • I made sure ALSA was starting when the Pi boots

All I hear is sort of white noise coming out of the jack regardless of whether aplay is running or not. I also made sure that it was a .wav file with these codecs: 22050khz, 16bit, mono, PCM Little Endian if that matters. But regardless of what wav or mp3 I use it does not work. The only noise I can get to work is the sine wave in the hello_world examples folder but with lots of noise. Any suggestions?

  • If you are on Raspbian and service pulseaudio status says it is running, try, sudo service pulseaudio stop and see if that helps. You might also have a look at alsamixer -- on the pi it is just one "PCM" volume; you can turn it up and down w/ + and -. – goldilocks Jun 2 '15 at 15:55
  • Thanks for the reply. I did that and it returned something to the effect of "service unrecognized"! Does that mean I have to install pulseaudio? Do I need that to get audio working? I don't have a problem with the volume it just doesn't work it all. – NULL Jun 2 '15 at 17:52
  • If at all possible I would like to have sound without pulseaudio. Should my sound have worked on a new version of Raspbian or do you always have to fix it? I have seen a couple tutorials about it but wasn't able to get them to work. – NULL Jun 4 '15 at 10:27
  • No you do not have to use pulseaudio and unless you need it for some particular purpose which it provides (e.g. multiplexing), then I recommend not using it. Beware though that some apps (e.g. mpg123) can be built with multiple backends (for pulse and alsa) and may default to pulse. I don't think aplay is like that (but I don't think aplay does anything but PCM, i.e., .wav but not .mp3). Your test sounds fine to me, although you might have a look at the various parameters (man aplay) to see if setting those manually helps. – goldilocks Jun 4 '15 at 12:24
  • After running echo 'snd_bcm2835' >> /etc/modules I was able to get omxplayer to play the wav files and mp3s. I didn't know what it meant put it worked! I haven't tried aplay again yet. Will update when I do. – NULL Jun 4 '15 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.