I installed Cheese and VLC from the Raspbian repositories. The programs worked perfectly until I tried to restart the computer. Now, after executing startx I get a black screen. After killing X I see the following error message:

No protocol specified

waiting for X server to begin accepting connections .
No protocol specified
No protocol specified
.. Server terminated successfully (0). Closing log file.

xinit: giving up
xinit: unable to connect to X server: Bad file descriptor
xinit: server error

Can anyone help me to fix this error?

  • 1
    Can you paste /var/log/Xorg.0.log please?
    – Munkeh
    Oct 16, 2012 at 14:14
  • Are you using the standard install other than those applications you have installed?
    – Jivings
    Oct 17, 2012 at 8:07
  • They've been downloaded from the raspbian repositories Oct 17, 2012 at 15:37
  • Have you solved this issue or has it been resolved? If so, could create a self-answer and mark it as such. We are trying to get the site Q:A ratio up, and this question appears to have been inactive for quite a while. Feb 25, 2014 at 17:51

2 Answers 2


Check your ~/.xinitrc file. It sounds like something listed there to be launched at execution of the startx command isn't starting properly and is hanging, making it look like X hasn't started. (It probably has, it's just showing a black background. Misleading, I know!)


Check how much free space you have available in the partition that your home directory is located on, as X creates configuration files and temporary files in your home folder.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.