2

I just compiled a custom kernel for Raspberry pi. However, when trying to boot it up using QEMU I seem to be getting errors as shown here. Is there anything obvious that I'm doing wrong? Is there any more information I can provide to make the problem clearer?

4
  • 1
    what command are you using to run qemu? I found that some of the parameters are very specific, like -m 256 being the most memory you could allocate.
    – rob
    Commented Jun 5, 2015 at 7:48
  • @rob The command I'm using is : qemu-system-arm -kernel vmlinux -hda kernel.img -machine versatilepb
    – user7340
    Commented Jun 5, 2015 at 9:22
  • 1
    Not sure if it will help but here was what I used witha prebuild raspbian image qemu-system-arm.exe -kernel kernel-qemu -cpu arm1176 -m 256 -M versatilepb -no-reboot -serial stdio -append "root=/dev/sda2 panic=1" -hda raspbian.img
    – rob
    Commented Jun 5, 2015 at 12:45
  • I have added a new question about qemu and crosscompiled raspberry kernel with busybox in initramfs: raspberrypi.stackexchange.com/questions/56302/…
    – 42n4
    Commented Oct 13, 2016 at 15:35

1 Answer 1

0

I'm trying to do the same thing, I haven't ran into this exact problem, but I found that this resource: https://github.com/dhruvvyas90/qemu-rpi-kernel, if you look at the README's in the tools directory, it indicates that the kernel must be compiled with specific hardware disabled since it is not emulated in qemu. It appears that the repo also contains a script for automatically compiling the kernel for qemu. Hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.