1

I have a Raspberry Pi model B+ I'm trying to read RFID tags using the Parallax RFID reader. I've downloaded the python gpio tools, as well as libnfc. When I run nfc-list, it says no devices found.

enter image description here

When I run minicom, nothing is read. What should I do to find the problem?

2
  • I got it. I had to connect the VCC to the 5V and disconnect from the 3V.
    – Irwin
    Commented Jun 9, 2015 at 16:42
  • 1
    I'm glad you found the solution. Could you please post your solution as an answer and then self accept it please?
    – Jacobm001
    Commented Jun 9, 2015 at 18:55

1 Answer 1

1

The Parallax RFID Reader needs an input voltage of 5V. This connects to the VCC. It is enabled by connecting the enable line to a pin with 0 bit value. The RFID reader needs to be level shifted, from 5V to 3V. Following this guide, http://www.instructables.com/id/Pi-Cubed-How-to-connect-a-33V-Raspberry-Pi-to-a-5V/ I connected in series, the output from the RFID reader (SOUT) to 2 100 ohm resistors, and then connected that to RXD0 on the breadboard. RXD0 corresponds with GPIO 15 on the Raspberry Pi. I was then able to read data from the serial port.

Still no luck with nfc-list

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.