2

After entering: apt-get install python3-pip on bash for my Raspberry Pi 2 (Model B) I get this output (linky).

I've tried the usual dance of apt-get install -f, apt-get update and apt-get upgrade to no avail. My device can access the outside world (ie - can ping google.com).

It's a freshly installed Raspbian image downloaded from the website, and all that I have done since getting it configured is to create a new user.

Any suggestions on how to proceed from here?

EDIT: wget http://mirrordirector.raspbian.org/raspbian/pool/main/e/expat/libexpat1-dev_2.1.‌​0-1+deb7u1_armhf.deb yields:

--2015-06-10 14:08:43--  http://mirrordirector.raspbian.org/raspbian/pool/main/e/expat/libexpat1-dev_2.1.%E2%80%8C%E2%80%8B0-1+deb7u1_armhf.deb
Resolving mirrordirector.raspbian.org (mirrordirector.raspbian.org)... 5.153.225.207, 2001:41c9:1:3ce::11
Connecting to mirrordirector.raspbian.org (mirrordirector.raspbian.org)|5.153.225.207|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2015-06-10 14:08:43 ERROR 404: Not Found.

--2015-06-10 14:08:43--  http://mirrordirector.raspbian.org/raspbian/pool/main/e/expat/libexpat1-dev_2.1.%E2%80%8C%E2%80%8B0-1+deb7u1_armhf.deb
Reusing existing connection to mirrordirector.raspbian.org:80.
HTTP request sent, awaiting response... 404 Not Found
2015-06-10 14:08:43 ERROR 404: Not Found.
  • What happens if you try wget http://mirrordirector.raspbian.org/raspbian/pool/main/e/expat/libexpat1-dev_2.1.0-1+deb7u1_armhf.deb, or point a browser to mirrordirector.raspbian.org/raspbian/pool/main/e/expat? – goldilocks Jun 10 '15 at 14:06
  • updated question. Reckon it's a DNS problem? – OldTinfoil Jun 10 '15 at 14:11
  • No, wget says "unable to resolve host address" in that case. If you're working on another computer in the same location, you could try navigating to http://mirrordirector.raspbian.org/raspbian/pool/main/ (it is WWW browsable) to see if that works. – goldilocks Jun 10 '15 at 14:37
  • Yeah - I tried it on my desktop (same network) and it resolves fine. – OldTinfoil Jun 10 '15 at 14:38
8

For some reason, I couldn't resolve the default mirror's repositories. I added the University of Oxford's mirror (list of all Raspbian mirrors) to my /etc/apt/sources.list.

For the folks who may follow, my sources.list file now looks as follows:

# Original mirror
#deb http://mirrordirector.raspbian.org/raspbian/ wheezy main contrib non-free rpi

# Oxford University mirror
deb http://mirror.ox.ac.uk/sites/archive.raspbian.org/archive/raspbian wheezy main contrib non-free rpi


# Uncomment line below then 'apt-get update' to enable 'apt-get source'
deb-src http://archive.raspbian.org/raspbian/ wheezy main contrib non-free rpi
  • 1
    I had this, the weekend I got my first RPi, and I thought (I had a) "broken RPi"! Turns out that the mirrordirector.raspbian.org is a URL that gets resolved into a URL for a mirror that is deemed "most suitable" for the particular caller. However if that system is not working for any reason then you get "404" errors and no packages - even if there ARE mirrors up and ready to supply all you want in the way of RPi packages. Having a known good mirror for your own geo-location as a standby in the /etc/apt/sources.list (or in a file in ./sources.list.d/ sub-dir) is a good fall-back! – SlySven Jan 24 '16 at 2:56
  • This example is for wheezy I was able to successfully use it to download jessie by replacing each instance of wheezy with jessie. Thanks for the helpful example. – JulianHarty Apr 3 '16 at 13:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.