1

I have been unable to SSH into my Pi 2 using PuTTY on my Windows 7 machine. Every time i try to login, it gives me an error "Connection refused". Can somebody please help? I use Raspbian.

  • 3
    "Connection refused" implies there is nothing listening on the port at that address. So if the address is correct, there is probably no sshd running on the pi. – goldilocks Jun 14 '15 at 16:02
3

it seems that package openssh-server isn't installed. Why don't you installing it using

sudo apt-get update && apt-get install openssh-server

and then to make sure it starting, please use this code

sudo service ssh start
| improve this answer | |
3

If it's a fresh raspbian. SSH will be enabled by default. You might wanna configure network though if you're using wifi. It should work on eth0 out of the box. Make sure Ip you're connecting is right. Also login username should be pi.

Hope it helps.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.