2

One of these 7-inch babies followed me home:

https://www.olimex.com/Products/OLinuXino/A13/A13-LCD7-TS/resources/S700-AT070TN92.pdf

When I assemble the micromonitor, the RPi2 boots right up, and startx works. But...

The display configurator says the monitor is 656x512, contradicting that PDF. The pixels are fuzzy, because 512 framebuffer scanlines > 480 LCD scanlines. And the active area has a black 8-millimeter border, which loses me several square centimeters of area.

Did I mention I turned on overscan and the problem did the opposite of go away? Also raspi-config won't tell me if it thinks the switch is on.

What's the next step in basic 7-inch LCD TLC?

3

You might need to specify hdmi mode in config.txt to force Rpi to a certain resolution.

Follow these steps :

  1. sudo nano /boot/config.txt

  2. locate following line.

    Uncomment to force a specific HDMI mode (this will force VGA).

  3. Add these lines below it to force 800x480 custom mode.

    disable_overscan=1
    hdmi_group=2
    hdmi_mode=87
    hdmi_cvt 800 480 60 6 0 0 0
    

ctrl+o to write, and ctrl+x to exit.

sudo reboot

Hope it helps.

Also have a look at this link for other HDMI modes.

http://elinux.org/RPiconfig

  • 1
    More documentation about that here: github.com/raspberrypi/documentation/blob/master/configuration/… – goldilocks Jun 14 '15 at 18:09
  • Tx! It worked so well I'm a little overscanned now. No biggie! – Phlip Jun 16 '15 at 17:16
  • Edited my answer. Add this line : "disable_overscan=1" over hdmi_group=2 – dhruvvyas90 Jun 16 '15 at 19:24
  • I know this answer is 3 years old at least and I tried this answer on my PI 3 connected to Adafruit 7inch display. Now, it totally disabled the display. It won't even turn on. I need to somehow get to the Config.txt and reset it or I will have to REDO my PI 3 all together... that is going to suck! lol... – ThN Jul 3 '18 at 19:58
  • @ThN: You can plug the sd card on your computer and make changes to config.txt. – dhruvvyas90 Jul 4 '18 at 20:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.