2

Yesterday I had my WiFi adapter working. I took the Raspi home and installed drivers and manager for my Bluetooth adapter. Now, today, WiFi will not work. lsusb returns the device, but it will not show in WiFi config. Why is this and how do I fix it?

OS: Raspian Wheezy Model: Raspi model B Configuration: OS is on 8GB SD card, Swap on 512MB USB drive as primary with a secondary Swap file. Tenda wireless adapter W311MI. Kensington HUB with Tenda attached.

  • Is this with both the wifi and bluetooth adaptors plugged directly into the Pi? – Jivings Oct 18 '12 at 23:40
  • What does iwconfig show? You man need to run apt-get install wireless-tools to get iwconfig installed. – HeatfanJohn Oct 19 '12 at 1:35
  • Did it work with the adapter plugged in before? Is it in the same power supply? Same networks? Same everything? Was it only the software that changed? – XTL Oct 19 '12 at 9:09
0

(I can't ask for clarification yet, so apologies) If it worked before, it should work now, so something has changed. Re-installing the wireless tools package is unlikely to do anything (literally, if it worked before you already have it installed).

Two possibilities: 1. It's a power issue related to powering both dongles. 2. It's a software issue.

There are a few things to try: 1. Plug both adapters into the Pi, see if it works. 2. Plug both adapters into a powered USB hub, see if it works. [My feeling is this second option is more likely to work.] 3. Take the BT adapter out again and see if WiFi works, just to be sure.

Let us know what happens with these alternatives for further diagnosis.

  • With them both plugged into a powered hub, they both work. Thank you – ITman Oct 23 '12 at 21:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.