1

I run Raspbian. Everything worked fine until now, when it seems I can't use any command on my Raspberry Pi. I tried to reboot. And now it doesn't connect to wifi.

@raspberrypi: sudo su

-bash: /usr/bin/sudo: cannot execute binary file

also:

@raspberrypi ~ $ ls /usr/ Segmentation fault

After connecting to a display, I get the following log. (ilustrated in a picture)

enter image description here

3

I think you will have to re-image the SD card.

You seem to have serious corruption.

Any idea what caused the problem?

  • well, I don't have a clear idea. I get alot of "Segmentation fault" errors, when recording using a Raspicam and cancel the execution. I ignored them. But i don't think this would have been the problem. – iulian Jun 15 '15 at 19:22
  • I should have checked that you get the same problem with commands after re-boot. Or is it just a wifi problem after re-boot? – joan Jun 15 '15 at 19:39
  • after reboot my raspberry doesn't work anymore. I will connect it to a display to see if raspbian boots. – iulian Jun 15 '15 at 19:45
  • This isn't necessarily because of fs corruption, but I agree you might as well start over again by re-installing the OS. I also recommend you use the most recent Raspbian image if that isn't what you have. It wouldn't just be cancelling execution either, although that is a puzzling statement since something that segfaulted is already dead and cannot be cancelled. Unfortunately diagnosing it via online Q&A is not very feasible, so you will have to settle for mysterious. – goldilocks Jun 15 '15 at 19:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.