6

I am trying to get an original model Raspberry Pi working. I've installed 2015-05-05-raspbian-wheezy, and if I boot with a TV connected via composite, I get image on the screen and it gets as far as the raspi-config screen. So far, so good, but my wish is to perform a "headless" install - without screen & keyboard. So, I've connected the Pi to my local network via wired connection to my router. I have another computer, and I'm trying to ssh into the Pi from it.

sudo arp-scan --interface=wlan0 --localnet
Interface: wlan0, datalink type: EN10MB (Ethernet)
Starting arp-scan 1.8.1 with 256 hosts (http://www.nta-monitor.com/tools/arp-scan/)
192.168.100.1   00:0c:c3:7f:7e:63   BeWAN systems

1 packets received by filter, 0 packets dropped by kernel
Ending arp-scan 1.8.1: 256 hosts scanned in 1.948 seconds (131.42 hosts/sec). 1 responded

That's my router. In the router's config panel, I can see the Pi and that it has an IP - in this case, 192.168.100.39.

ssh:

ssh pi@192.168.100.39
ssh: connect to host 192.168.100.39 port 22: No route to host

ping:

ping 192.168.100.39
PING 192.168.100.39 (192.168.100.39) 56(84) bytes of data.
^C
--- 192.168.100.39 ping statistics ---
75 packets transmitted, 0 received, 100% packet loss, time 74210ms

I got it through a couple of times, but the statistics look like 141 packets transmitted, 1 received, 99% packet loss, time 140674ms

nmap:

nmap -Pn 192.168.100.39 -p 22

Starting Nmap 6.47 ( http://nmap.org ) at 2015-06-16 15:03 EEST
Nmap scan report for 192.168.100.39
Host is up.
PORT   STATE    SERVICE
22/tcp filtered ssh

Nmap done: 1 IP address (1 host up) scanned in 2.82 seconds

Around the same time as I got a few ping requests through, the output from ssh changed to ssh: connect to host 192.168.100.39 port 22: Connection timed out sometimes, no route to host as before on other times.

Edit: I now get consistent, sensible ping responses, with 0% packet loss. I did not change anything, so this is weird, but a change for the better. Also, the Pi is now visible with arp-scan:

arp-scan --localnet
Interface: wlan0, datalink type: EN10MB (Ethernet)
Starting arp-scan 1.8.1 with 256 hosts (http://www.nta-monitor.com/tools/arp-scan/)
192.168.100.1   00:0c:c3:7f:7e:63   BeWAN systems
192.168.100.39  b8:27:eb:f9:54:da   (Unknown)
  • Have you enable SSH in RPi ?Please Let me know, i tried same thing yesterday it is working fine for me – AKASH Jun 16 '15 at 12:23
  • What does it say when you try to ssh to rpi ip ? – dhruvvyas90 Jun 16 '15 at 12:41
  • Oh yeah, I forgot that (doh!). Updated. – appas Jun 16 '15 at 12:44
  • No I haven't, it's a fresh, untouched flash of the image. It is my understanding that sshd should be enabled by default (?). – appas Jun 16 '15 at 12:44
  • 2
    It's enabled by default in raspbian wheezy. – dhruvvyas90 Jun 16 '15 at 13:08
1

On your computer download a program named PuTTy and put the IP address of you Raspberry Pi into it and select the connection type as SSH. This will open a window, you will be prompted to enter your login and password for your Raspberry Pi.

If you want to run fully headless, I recommend using a program called VNC viewer, which allows you to view the Raspberry Pi desktop from your computer wirelessly.

  • 1
    I'm using the OpenSSH client, version 1:6.7p1-6 on Debian. I have inserted the output of an attempted ssh connection to the OP. I'm aware of VNC, but for now, I have no control of the machine over ssh, which is the problem to begin with. – appas Jun 16 '15 at 23:06
  • 1
    I don't knew if you can actually connect because you didn't say yes or no. Can any other device with ssh on your network connect the the pi? – Registered User Jun 17 '15 at 3:50
0

It happened to me once when using the raspi-config utility to enable SSH that something seemed to behave weird, since then i just enable it using the shell.

When making a new install of Raspbian I immediately enable SSH as:

sudo systemctl enable ssh
sudo systemctl start ssh

Then I can go and SSH to PI from my PC, then update, upgrade and reboot.

sudo apt-get update
sudo apt-get -y upgrade
sudo reboot

Then install Samba on it:

sudo apt-get -y install samba

What Samba gives me is the ability to see the PI`s hostname when I scan the network.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.