2

I've setup my Raspberry Pi as a kiosk, on a portrait-mounted HDMI TV. After setting display_rotate=1 and the GPU split to 128MB in /boot/config.txt the screen is now the correct orientation.

However the bottom half of the screen is black. I know the desktop is extending the full height of the TV because the "Raspberry" background is in the middle of the screen, and windows fill beyond the edge of the drawn area.

The same is true for both the GUI and the terminal (even during boot). I'm stumped as to why this is happening, and I can't find anything online referring to this issue.

Anyone have any ideas?

1

Have you tried increasing the memory split? I had no luck with my little portrait display project until I increased it to 256 IIRC. I also had some odd issues when I disabled the logo display on boot. Note the ability to do this may vary depending on which RPi you're using.

  • It's a Raspberry Pi B+. All the guides I checked suggested 128M would be sufficient, however I'll try cranking it up to 256. The device does very little anyway. – Kristian Williams Jun 18 '15 at 7:11
  • Increasing the GPU memory split to 256M had no effect. – Kristian Williams Jun 18 '15 at 7:19
  • Mine was an old model B. I've since upgraded to a 2B for my application. It's interesting that the command line is going it as well as the X GUI. My display required display_rotate=3, but that shouldn't make any difference. On one display, I did have to use hdmi_mode=82 to force 1080p mode. – bobstro Jun 18 '15 at 14:32
  • Based on pastebin.com/GLLq5NhC, my TV doesn't support HDMI mode 82. – Kristian Williams Jun 19 '15 at 7:34
  • This worked for me on an rpi Zero W – Stoopkid Mar 4 at 16:33
0

Finally got it working with the following settings in /boot/config.txt:

# For more options and information see
# http://www.raspberrypi.org/documentation/configuration/config-txt.md
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
overscan_left=0
overscan_right=0
overscan_top=0
overscan_bottom=0

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1080
#framebuffer_height=1920

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable the lirc-rpi module
#dtoverlay=lirc-rpi

# Additional overlays and parameters are documented /boot/overlays/README
display_rotate=1
gpu_mem=256

Hopefully they are useful to others in my position.

0

I encountered the same issue where around the bottom 40% (ish) of the screen was cutoff when display_rotate=1 or display_rotate=3. Updating the firmware worked for me. I believe this had to do with this firmware bug.

I am using a Pi2 model B with gpu_mem=256.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.