4

I'm using the Debian Wheezy 2012-8-18 distribution on a Raspberry Pi model B. I have set the SSH server to turn on by default, and connected it to my Ethernet switch, where the router uses DHCP.

The switch shows the Pi is connected, but the arp-scan from my desktop shows only the router, nothing else. Has the Ethernet of the Raspberry Pi failed to start correctly? Is there a configuration to turn on DHCP client of Raspberry Pi? I will need to get a monitor I need to log in locally.

  • Can the Raspberry Pi ping the router? What does ip route on the Raspberry Pi say? Can the router detect the switch? – ArchHaskeller Oct 20 '12 at 18:15
3

Sort of multiple questions there, so multiple answers...

To find the Pi on the network, you could try Advanced IP Scanner which has always worked for me to find the IP address across the network.

Making the Pi appear on the network for Windows machines to see in the Network view in Explorer is done through a package called 'samba' that can be installed on the Pi (sudo apt-get install samba).

Probably the most important bit: In terms of the dhcp client, this should already be automatically ON on the Pi. Can you do 'ifconfig' and paste the output here so we can see if the Pi actually has an IP address or not?

  • The problem was with the voltage the pi was receiving. I was using a cheap usb to micro usb cable with my custom built power supply, which was a meter long. Now i cut the wire making the length just 2 cm, and the voltage increased to 4.91 volts at the pi power in (TP1 to TP2 is still 4.65 V). Now the problem is not there. Ethernet is working perfectly.Thanks for the help Haskeller and recantha – malshan peiris Oct 21 '12 at 14:55
  • 1
    @malshanpeiris It would be helpful if you answered your own question with your fix. That way others will be able to find the answer easily. You'll also get some rep :) – Jivings Oct 21 '12 at 23:41
  • @malshanpeiris did you have to re-install the system or it just worked after fixing the power supply ? – Xsmael Oct 22 '17 at 17:30
0

As someone who found this page looking for answers to my own issue, my solution was that my Pi had the same IP as another machine on the network. I manually set the ip of my Pi by opening my ip config with sudo nano /etc/dhcpcd.conf then, after all the existing bits I made the end where you set your ip be :

interface eth0

static ip_address=192.168.0.235/24
static routers=192.168.0.1
static domain_name_servers=192.168.0.1

interface wlan0

static ip_address=192.168.0.230/24
static routers=192.168.0.1
static domain_name_servers=192.168.0.1

Not the answer you're looking for? Browse other questions tagged or ask your own question.