4


I'm currently trying to set up my Raspberry Pi with ArchLinuxARM. Everything went fine so far but the display has a horribly low resolution, 640x480!
I'm using a HDMI to VGA converter box and an Acer monitor that normally can do a resolution of 1920x1080 @ 60 Hz.
I know this is something that is widely discussed but I already did tons of google research and tried a lot but nothing seems to change anything. My current /boot/config.txt, but I've already tried many different combinations:

hdmi_safe=1
disable_overscan=1
hdmi_group=1
hdmi_mode=16
hdmi_drive=2
config_hdmi_boost=4
sdtv_mode=2
sdtv_aspect=1
hdmi_edid_file=1
## ... and overclocking settings on Turbo, but rather as a test

Also:

$ /opt/vc/bin/tvservice -s
state 0x12001a [HDMI DMT (4) RGB full 4:3], 640x480 @ 60.00Hz, progressive

$ /opt/vc/bin/tvservice -m CEA
mode 4: 1289x720 @ 60Hz 16:9, clock:74MHz progressive
mode 16: 1920x1080 @ 60Hz 16:9, clock:148MHz progressive

$ /opt/vc/bin/tvservice -m DMT
mode 4: 640x480 @ 60Hz 4:3, clock:25MHZ progressive

When I change framebuffer_width and framebuffer_height to something higher, the text gets smaller but also blurry, like theres no change in resolution but just in font size. I have black bars of about 10% at top, bottom, left and right of the screen, that don't change by changing the overscan attributes in the config.txt, neither with positive nor negative values.
I can login via SSH and change the HDMI mode to CEA 16 DVI with

$ /opt/vc/bin/tvservice --explicit="CEA 16 DVI"

And the output of tvservice -s tells me that the mode is now the status but the monitor of the pi just turns black (different shades of black, depending on what hdmi mode I try) and stays that way. When I change the HDMI mode to 16, and reboot, the messages that appear on the screen actually have the right resolution but it reboots into HDMI mode 4 CEA again.
I've already tried commenting out disable_overscan, using the overscan values, using different HDMI modes (1,4,16,31,32,47,68,69,71,71,72,73 with hdmi_group=2 and 1,4,16 with hdmi_group=1), using /opt/vc/bin/tvservice -d and enable hdmi_edid_file=1, changing sdtv_aspect and choosing different overclocking settings, and now I have the feeling I'm just looking at the wrong place...

I have already set up the raspberry pi with the same setting (at least I thought it would be the same) and the resolution was fine. I don't know what I am doing wrong.

I hope you can help me!

  • 1
    Are you sure your HDMI->VGA adapter supports 1920x1080? Could you perhaps post a link to the actual adapter you have in your possession? – Phil B. Jun 19 '15 at 12:48
  • FWIW - I use an HDMI->VGA adapter which works fine in 1920x1080 without needing to make any config.txt modifications - here is the link to the one I use: amazon.com/gp/product/B00G9UWP94 . – Phil B. Jun 19 '15 at 18:56
  • I can't remember which one I bought, but also over amazon and it was a bit cheaper, about 5 Euro. I am sure that my adapter supports it because when I switched the hdmi mode over tvservice and then rebooted I could see the right resolution but only the shutdown messages. But before that the screen was blanking, so I was not able to use any terminal. – matkin Jun 19 '15 at 19:38
3

So, it works now. It seems to be the solution was to comment out hdmi_safe=1. I tried to disable everything that does not change anything and ended up with this /boot/config.txt:

hdmi_group=2
hdmi_mode=47
hdmi_drive=2

Thanks to everyone who helped!

  • do you mean comment out hdmi_safe=1 or uncomment it? I don't see hdmi_safe=1 in the full config you listed. – jaynp Sep 4 '16 at 23:46
  • I commented it out. In the file listed in the question it was uncommented. The file that is listed in the answer is everything that was needed. I didn't write down explicitly which options were also in the file, that I commented out. – matkin Sep 5 '16 at 6:07
  • I edited my answer. – matkin Sep 5 '16 at 6:24
1

Try adding this to config.txt :

hdmi_force_hotplug=1

  • Tried it - doesn't change anything... – matkin Jun 20 '15 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.