2

I have looked at all kinds of tutorials, I modified the /boot/config.txt by adding hdmi_drive=2 and sound just does not work or if it does it always is over analog out.

I just want sound over HDMI to function. I used berryboot on my RPi 2 and tried some of the available distros. What I ended up doing is installing Raspbian then installing RetroPie because the retropie distro had issues with bluetooth, since I'm using a bluetooth controller this was not an option.

Is there a specific order for the /boot/config.txt file? I just added hdmi_drive=2 to the end.

Thank you for all assistance.

5

There's another setting in your /boot/config.txt that affects sound: hdmi_group

If you want sound over HDMI, config.txt should have both:

hdmi_group=1

hdmi_drive=2

You need them both set because hdmi_group=1 tells the kernel we are using CEA mode (for TV's, has sound) instead of DMT mode(for monitors, no sound) and hdmi_drive=2 tells the kernel to use HDMI if available. (HDMI mode has sound, DVI does not.)

If that doesn't work, verify that your snd-bcm2835 module being is loaded on boot (/etc/modules) and not blacklisted...

  • This worked for my HDMI TV. – Kris Krause Jan 11 '17 at 19:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy