2

This question already has an answer here:

I am working on a project similar to the one at http://www.instructables.com/id/Raspberry-Pi-Wall-Mounted-Google-Calendar/?ALLSTEPS

Similarly, I need my pi to stay on constantly. I have the regular Raspbian OS installed and I am using Iceweasel browser to run a web application all day.

I have tried every single one of these suggestions from this link http://www.bitpi.co/2015/02/14/prevent-raspberry-pi-from-sleeping/

Yet the pi fails to stay on longer than 10 minutes. Any help would be greatly appreciated.

marked as duplicate by Jacobm001, RPiAwesomeness, hildred, mpromonet, Ghanima Jun 25 '15 at 20:50

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Just as a side-comment - I picked up an Azpen A745 android tablet last weekend for $30 bucks at Microcenter - and it has a Google Calendar. In a few easy steps you can disable screen dimming/sleep in Android and you have a wallmounted Google Calendar solution :) Display viewing angle is not fantastic, but this saves you a lot of work - unless you are of course committed to using the rPi for this :). I use mine as a terminal for RuneAudio - I velcroed it to the wall. – Phil B. Jun 22 '15 at 17:47
  • Thanks @PhilB. but I am not running Google Calendar. Im running a web application I built and also its on 40 inch screen. But thank you for introducing me to RuneAudio ! Can't wait to try that out – Javed Ali Jun 22 '15 at 19:12
  • Thanks @Huygens I tried that one as well. I completely reinstalled the OS and the solution below worked – Javed Ali Jun 24 '15 at 13:36
  • You can always install gnome-utils and gain control over the screensaver via the preferences menu. Screen banking is easy to control there. – SDsolar Jan 10 '17 at 14:36
2

I don't know why it's not working since the last option mentioned in that post (lightdm configuration - Xsession blanking) worked pretty good for me.

Here is the easiest way for you.

Install xscreensaver by "sudo apt-get install xscreensaver"

Once installed, go to Rpi's desktop "Menu" (left top corner) [I'm assuming that you're running a raspbian?]

Go to preference ---> screensaver.

You will see a screen saver main menu. In mode : section, select "disable screensaver" and close.

Reboot Rpi. It should work now.

====================================

Also have a look at links below:

Disable screen blanking in X-Windows on Raspbian

How do I prevent the screen from going blank?

Hope it helps.

Not the answer you're looking for? Browse other questions tagged or ask your own question.