I have several Pi's running the latest version of Raspian. I have just converted my internet to Google Fiber (which has both 2.4 and 5.0). The B+ models are not having any problem with the wifi. However, the B models are not working and the errors are inconsistent. Sometime it sees the network broadcast (along with the others in the area). Sometimes it doesn't. Sometime I get an IP address then it drops, other times nothing. I am having problems isolating the problem. I have spent a significant amount of time working with the interface file. Hardwired to a router works fine. I don't see how but could the broadcasting of the 5.0Ghz be causing a problem? All other devices are working fine.

1 Answer 1


One of the improvements in the + models was the amount of power that can be reliably delivered via USB. Early pis actually had individual polyfuses limiting output per port to ~150 mA.

Those were removed at some point (there's no revision or model number to indicate this), but I believe the total system is still limited to 700 mA, meaning you won't necessarily be able to power any and all USB 2.0 devices, which may demand up to 500 mA. I have a hard drive that will not run off a B because of this (it needs a powered hub), but works fine directly connected to a B+.

Operating at 5.0 Ghz may be a factor here too. While it probably doesn't increase overall power consumption, I am pretty sure it does mean higher peak consumption, and this peak draw is the problem.

  • Thanks! I thought about that. I double checked and I am on a 5V 2amp connection. The funny thing is they worked prior to googel fiber. I am going to attempt to turn off the 5.0ghz. on the Wifi. Don't think I need to do anything on the dongle itself because it's an N and not a A/C.
    – GooberTek
    Commented Jun 23, 2015 at 14:53
  • 1
    It doesn't matter how big a supply you use. The A/B models will just not reliably provide the 500 mA that USB 2.0 devices might potentially use (but the +/2 models should).
    – goldilocks
    Commented Jun 23, 2015 at 15:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.