I'm planning to create a media center with Raspberry Pi. For that I would like to attach a 500 GB USB hard disk drive that I already own.

Right now, I'm trying XBian, but I already tried Raspbmc and the same thing happened. I'm using an 8 GB SD card for the OS, a 1.0 A cellphone charger to power the Raspberry Pi, Samsung LCD TV for display (HDMI).

From what I read I need a powered USB hub in order to power the USB hard disk drive, so I bought one. I bought a Soyntec powered hub with seven USB ports (Model Nexoos 395, just for the record).

If I connect the keyboard into one of the Raspberry Pi's USB ports and the hub on the other (without anything plugged into the hub and without powering the hub), everything works well. If I add a 16 GB pendrive in the hub (wihtout powering the hub), the Raspberry Pi recognizes the pendrive and works fine. If I unplug the pendrive from the hub, and I plug the hub's power cord in order to get it powered (without plugging any usb device, just the hub to the Raspberry Pi), everything works well.

The problem comes when I try to plug anything into the hub after is powered. If I plug either the pendrive (which worked in the hub before powering the hub) or the USB hard disk drive, the screen starts to "flicker" (black screen, back to normal for a second, black screen, and so on).

So the problem seems to be if I plug something into the hub when the hub is powered.... because if the hub is not powered, it seems to work. But if I don't power the hub I won't be able to use my hard disk drive which is my objective.

All the uses that I thought for my Raspberry Pi rely on the USB hard disk drive (media player, torrent seedbox, and NAS).

  • 1
    Have you checked this elinux.org/Rpi_USB_check-list? Have you tried everything plugged into the USB hub (keyboard included)? I have never heard of this brand of hub, you may want to try one of the verified working hubs from this list elinux.org/RPi_VerifiedPeripherals. Commented Oct 21, 2012 at 23:25
  • 2
    Strange, seems like the USB hub is drawing power from the Pi, despite being self powered.
    – Jivings
    Commented Oct 21, 2012 at 23:40

1 Answer 1


It's possible that the USB hub you have is trying to power the Raspberry Pi through the USB cable feeding into the Raspberry Pi. This is a common problem with USB hubs and may cause strange problems like you are experiencing. It sounds to me like it only does this when you plug something into the hub.

If you take a look at Logik LP4HUB10 power problem fixed, you'll see the procedure for fixing a different USB hub. It's called the "cut the red wire" solution and many Raspberry Pi owners have had to resort to it. It's a simple procedure. Even I managed to not mess it up (and I'm still using the hub three months on).

Essentially, some USB hubs don't obey the rules and send power up the USB cable as well as the signal that you want it to send from the peripheral.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.