0

I am using LIDAR Lite module (website) to calculate the distance and it uses I2C connection. I connect the pins out of the LIDAR into a level shifter since RPi accepts 3.3V. When I run the command sudo i2cdetect -y 1, almost all addresses are shown and they change every time I run the command again. The address of the LIDAR should be 0x62, but instead I am getting many addresses. I have tested the module on Arduino Uno and it works fine. I am using (RPi 2 model B 2014).

The help is highly appreciated.

9
  • What doed i2cdetect -y 1 show if you have nothing connected to the expansion header?
    – joan
    Jun 23, 2015 at 20:46
  • By the expansion header, do you mean the level shifter? If so, it shows nothing
    – coding4fun
    Jun 23, 2015 at 21:29
  • The expansion header is the row of 26 or 40 pins (depending on the model) on the side of the Pi. I'm not sure which model you have as the Pi2 only came out in 2015.
    – joan
    Jun 23, 2015 at 21:33
  • ohh. I have the latest one and it has 40pins and it shows nothing when I run i2cdetect
    – coding4fun
    Jun 23, 2015 at 21:35
  • 1
    The LIDAR should not have pull-ups fitted. I assume the LIDAR is pulling SDA/SCL to 5V. If you can't disable them then you have no choice but to use a level shifter, but I suspect the level shifter is causing the problem.
    – joan
    Jun 23, 2015 at 22:22

1 Answer 1

2

Your level-shifter is the problem. The LIDAR lite I2C uses 3.3V logic. (The 5V line feeds a regulator inside the unit.) The external trigger pin also uses 3.3v logic.

See their documentation here-

http://kb.pulsedlight3d.com/support/solutions/articles/5000550871-what-voltage-can-the-lidar-lite-pins-handle-

2
  • so I'll connect the sensor directly and it won't burn?
    – coding4fun
    Jun 24, 2015 at 8:20
  • 1
    Gald to help! They are great sensors! Jun 24, 2015 at 18:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.