I have installed raspbian on PI 2, and it always got lots of errors after rebooting. Sometimes I have to unplug the SD card and do fsck on my laptop (the second/ext4 partition), otherwise the PI 2 will end up with endless filesystem errors.

I have tried to re-flash the SD card, but same result. The SD card is a new one (16G class 10 of PNY). Is this because of the SD card? Thank you.

The power supply is 5V 1.2A, and I think it's enough for a keyboard and wifi adapter.

Here are some samples of the errors.

enter image description here

enter image description hereenter image description here

  • Looks like card is physically damaged. Not sure though. Did you try re-flashing a fresh image ? Jun 24, 2015 at 6:48
  • @dastaan I have tried to re-flash raspbian, and no good. I have also tried to flash ubuntu-mate, but cannot boot. However I have not face any errors when dd the image to the card. How can I test if the card is in good condition?
    – leetom
    Jun 24, 2015 at 7:19
  • Well, personally, I've not used any such utility. But this looks promising. askubuntu.com/questions/69932/… Also, if you have a spare SD card, you can give it a shot by burning raspbian to it. Since you're saying that, it failed booting ubuntu-mate as well, mostly it would be an SD card issue. Jun 24, 2015 at 7:28
  • 3
    Are you powering off properly? The most likely cause of a corrupted SD card is switching off the power while the SD card is being written.
    – joan
    Jun 24, 2015 at 7:28
  • @joan sometimes I have to unplug the power since the system is frozen. Anyway if that happened, it usually a filesystem corruption instead of a physical damage. I have tried to re-flash the OS but still same problem at first reboot.
    – leetom
    Jun 24, 2015 at 8:17

1 Answer 1


You could look into this, but I doubt any Pi 2 kernels were built that way. uname -a will tell you for sure.

Killing the power abruptly can cause filesystem corruption but it is actually very unlikely. It is more likely if the system is very busy at the time (which seeming "locked up" could actually mean "too busy to respond properly), but if this keeps happening over and over, there is something else going on.

If you are pulling the plug because it has locked up, you should look at /var/log/syslog afterward to see if anything interesting is indicated there as to why it did this.

There are millions of pis and unfortunately, they were not all made perfectly. This is perhaps inevitable, or perhaps a result of insufficient testing and quality control, but either way occasionally someone is going to get a lemon. There could be a problem with the SD card reader. But first you have to rule out a few things:

  1. The SD card itself. Get another one -- a brand new one -- and try that. If it still happens, re-format both cards however is most useful to you and put a bunch of photos or mp3s or whatever you have a bunch of on them, a least a GB or so. Then try using them as many places as you can and see if they are okay.

  2. The power supply. I think this is not very likely as well, but you should at least try it with two different 5V supplies that are both at least 1.5 A.

If you are consistently having this problem after that, you should contact the distributor you bought this from and explain the problem and that you have tried multiple SD cards and power supplies. I do not think they will argue, but if they refuse to take it back, please let us know in a comment here who they are.

  • Thank you! It's the power supply's problem. I tired with a 2.1A power bank, and there's no more errors.
    – leetom
    Jun 26, 2015 at 2:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.