2

On the website of raspberry pi 2 I read that the current draw for usb ports can be switched from 600mA to 1.2A. I searched around and I couldn't find anything that shows how to do that, I went to raspi-config but there's nothing there about power. What should I do?!

A friend suggested that power might be a problem because every time I connect a local router to my raspbian while I need to be connected to the internet over wifi my raspberry goes nuts and hangs and damages the SD card, and I have to do re-imaging again.

Also, my samsung charger has output of 9v-1.67A or 5v-2A together. Does that mean that it can manage the maximum rate? It is a fast adaptive charger.

4

I think you're looking for max_usb_current=1 in /boot/config.txt. There's a discussion on setting this on the RPi forums that covers power supply considerations.

  • I didn't see anything on this text file with the same line. Should I manually add the max_usb_current = 1 or with a # before it?! – Ahmed Al-haddad Jun 25 '15 at 3:58
  • 1
    just max_usb_current=1. Putting # before a line in config.txt comments it out. That setting will increase the power the RPi makes available over USB ports, but will do nothing to help if your power supply is inadequate. Do you see a colored multi-color square on the top right after booting? That's a sure sign that your power supply is a problem. There's also been [some discussion] (raspberrypi.stackexchange.com/questions/27708/…) of the topicon stackexchange. – bobstro Jun 25 '15 at 4:32
  • Oh got it :D. How about the Samsung charger? Any idea?! – Ahmed Al-haddad Jun 25 '15 at 5:02
  • 1
    You can also enable/disable high power mode by writing 1/0 to gpio 38. – joan Jun 25 '15 at 7:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.