3

disclaimer: I am new to OpenCV and Raspberry Pi, although I have a fair amount of experience with linux systems in general

Here is what I am attempting to accomplish:

  • I am trying to use a Raspberry Pi with OpenCV (version 3.0.0) to read a live video stream from a GoPro (or any camera with a live video output).

Here is my setup:

  • I have am running Raspbian 3.18.16
  • I have an STK1160 video capture card (USB connection)
  • I have read that in my version of Raspbian, the necessary drivers for the STK1160 (v4l2) are pre-installed. I have verified this with man v4l2-ctl

My problem:

  • When I try to load the driver with sudo modprobe bcm2835-v4l2, I get the following error: modprobe: ERROR: could not insert 'bcm2835_v4l2': Operation not permitted. I am able to read in video with the camera, so it is not an issue with the camera's connection (however, the video feed is bad and looks like this: https://www.youtube.com/watch?v=NHOFd74NCD0 must be a problem with the driver?)

  • In addition, when I run dmesg I get the following error:

bcm2835-v4l2: error -1 while loading driver

I've spent about two weeks searching for an answer to this problem and the closest issue that I've found to my problem is on this link: Camera, Ubuntu, modprobe bcm2835-v4l2 ERROR: could not insert 'bcm2835_v4l2': Operation not permitted

This user seems to have a very similar problem. However, I have a Raspberry Pi and I am not running Ubuntu. (I tried to ask this question on that thread but I don't have enough "reputation" yet).

Has anyone encountered this issue with a Raspberry Pi before?

Thanks!

  • I'd be pretty amazed if the Pi could handle a live video feed via a USB dongle. It is not very powerful. Have you seen any reports of success? – joan Jun 26 '15 at 17:55
  • Yea, I know someone who used the same model USB video capture card and a raspberry pi to capture live video. I am building off their project - only first I have to get it to work again! I should mention that I'm hoping to read in (and analyze) video at around 1fps. – nuskita97 Jun 26 '15 at 18:29
  • bcm2835-v4l2 is the driver for the official camera module , not a generic V4L2 driver – flakeshake Jan 23 '16 at 13:11
1

SOLVED: with the command lsmod, you can see which drivers are installed. I had v4l2_common installed. I successfully loaded this driver with sudo modprobe v4l2_common (insert correct driver).

And yes, the pi can handle a live video feed!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.