I bought a Raspberry Pi and a TL-WN725N Wi-Fi adapter ("supposed plug and play").

I tried different guides/tutorials to set up wifi dongle, but I did not manage to install it. Especially (UPDATE) Drivers for TL-WN725N V2 - 3.6.11+ -> 4.0.xx+

One weird thing is that, it does not appear in lsusb:

pi@raspberrypi ~ $ lsusb
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.

Do you have any idea to help me ?

  • 2
    Looks like USB device is not connected properly. Make sure you are using a good power supply with power rating enough to power Rpi's USB devices. Jun 27 '15 at 5:41
  • 1
    sometimes you need to install the wifi's firmware file and or kernel module. can you show the result of dmesg after pluging the dongle ? Jun 27 '15 at 10:07
  • 1
    show us what dmesg shows... in my case with this (v2) wifi dongle, i needed to copy firmware file to preoper directory and it worked like a charm... Jun 27 '15 at 12:48
  • 1
    I do not believe a driver could disconnect it in this sense, but an easy way to check would be to blacklist or move the driver, then plug it in and out. For a driver to do anything with a USB device, it must first be registered through the USB subsystem. This will be reported in dmesg. If the driver really has disabled it, not using the driver will leave it listable by lsusb.
    – goldilocks
    Jun 27 '15 at 18:12
  • 2
    Thanks @dastaan I plugged my RPi on the wall instead of using a power strip and it works :D
    – gerbevar
    Jun 28 '15 at 19:35

If you've already installed an out-of-tree driver from the thread you linked or still using the stock version, this may explain why the device disappears from lsusb. There is a firmware that is supposed to go with the driver, and if that is unavailable or incorrect, this driver code might explain why you're not able to see your device with lsusb: The wifi chipset seems to be powered down when rtl8188eu_hal_deinit() is called.

I had this problem with this adapter and that is what happened. You can confirm this by examining dmesg output. If you get this kind of error:

r8188eu 1-1.5:1.0: Direct firmware load for rtlwifi/rtl8188eufw.bin failed with error -2  
r8188eu 1-1.5:1.0: Firmware rtlwifi/rtl8188eufw.bin not available

then you'll need to install the firmware. If you installed the correct module corresponding to your kernel version, try installing this firmware in /lib/firmware/rtlwifi/.

Otherwise (if you didn't install the corresponding module to your kernel version), you can try this link or this one. Please provide the output of uname -a and dmesg if you don't understand which file should be downloaded.

  • I have no wish to get in the middle of a perfectly good argument, but for the record: The pastebin reflects the results of a fresh burn of 2015-05-05-raspbian-wheezy.img which I then walked over to my RPi 2B and booted off of with a wired Ethernet connection and the TP-Link USB adapter inserted. Once I connected via ssh, I did not physically touch the RPi during the captured session. I did not install any drivers other than the download reflected during the captured session shown in pastebin.
    – bobstro
    Jun 29 '15 at 18:29
  • Yes @bobstro, I was wrong in my first comment. I was just angry my answer was completely rewritten wihout notice. I did not bother to check that's also absolutely right :) I was just mad of goldilocks behaviour. Jun 29 '15 at 18:32

You need to determine if this device ever registers. Start from a fresh boot and then:

dmesg | grep 0bda

0bda is the ID for Realtek, who make the chipsets used in these dongles. If you see nothing, try dmesg | grep usb and see what idVendor's are listed.

The other part of the ID is idProduct, which will be either 8176 or 8179 (there are two versions of the TL-WN725N). The former should have an in-tree1 driver, try sudo modprobe 8192cu. The latter requires an 8188EU driver which you have to install as per the directions you've already found.

1. The "tree" in "in-tree" and "out-of-tree" refers to the official linux kernel source, which includes most drivers for most things, or at least, most of the drivers that are available for the linux kernel. However, there are things that aren't included due to licensing issues, or because the driver was not submitted to or was rejected by the people in charge of the kernel. These tend to be a much bigger hassle.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.